Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974506 - [abrt] cups-1.6.2-8.fc19: _dbus_hash_table_lookup_int: Process /usr/sbin/cupsd was killed by signal 11 (SIGSEGV)
Summary: [abrt] cups-1.6.2-8.fc19: _dbus_hash_table_lookup_int: Process /usr/sbin/cups...
Keywords:
Status: CLOSED DUPLICATE of bug 979748
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5ea1bd198045da2603c80494d01...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-14 10:04 UTC by Tim Waugh
Modified: 2013-07-01 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-01 14:11:59 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (9.03 KB, text/plain)
2013-06-14 10:04 UTC, Tim Waugh
no flags Details
File: cgroup (154 bytes, text/plain)
2013-06-14 10:04 UTC, Tim Waugh
no flags Details
File: core_backtrace (1.07 KB, text/plain)
2013-06-14 10:04 UTC, Tim Waugh
no flags Details
File: dso_list (3.43 KB, text/plain)
2013-06-14 10:04 UTC, Tim Waugh
no flags Details
File: environ (142 bytes, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details
File: maps (16.98 KB, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details
File: open_fds (517 bytes, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details
File: proc_pid_status (891 bytes, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details
File: var_log_messages (305 bytes, text/plain)
2013-06-14 10:05 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2013-06-14 10:04:46 UTC
Description of problem:
Enabled FileDevice in /etc/cups/cups-files.conf.

Version-Release number of selected component:
cups-1.6.2-8.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/sbin/cupsd -f
crash_function: _dbus_hash_table_lookup_int
executable:     /usr/sbin/cupsd
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 _dbus_hash_table_lookup_int at dbus-hash.c:1081
 #2 dispatch_timeout_callback at ../avahi-common/dbus-watch-glue.c:105
 #3 avahi_simple_poll_dispatch at simple-watch.c:570
 #4 avahi_simple_poll_iterate at simple-watch.c:605
 #5 avahi_simple_poll_loop at simple-watch.c:646
 #6 thread at thread-watch.c:71

Comment 1 Tim Waugh 2013-06-14 10:04:50 UTC
Created attachment 761196 [details]
File: backtrace

Comment 2 Tim Waugh 2013-06-14 10:04:53 UTC
Created attachment 761197 [details]
File: cgroup

Comment 3 Tim Waugh 2013-06-14 10:04:56 UTC
Created attachment 761198 [details]
File: core_backtrace

Comment 4 Tim Waugh 2013-06-14 10:04:59 UTC
Created attachment 761199 [details]
File: dso_list

Comment 5 Tim Waugh 2013-06-14 10:05:04 UTC
Created attachment 761200 [details]
File: environ

Comment 6 Tim Waugh 2013-06-14 10:05:08 UTC
Created attachment 761201 [details]
File: limits

Comment 7 Tim Waugh 2013-06-14 10:05:11 UTC
Created attachment 761202 [details]
File: maps

Comment 8 Tim Waugh 2013-06-14 10:05:15 UTC
Created attachment 761203 [details]
File: open_fds

Comment 9 Tim Waugh 2013-06-14 10:05:19 UTC
Created attachment 761204 [details]
File: proc_pid_status

Comment 10 Tim Waugh 2013-06-14 10:05:22 UTC
Created attachment 761205 [details]
File: var_log_messages

Comment 11 Tim Waugh 2013-06-14 10:07:09 UTC
I think the cause of this was 'systemctl restart cups.service'.

Comment 12 Tim Waugh 2013-07-01 10:31:57 UTC
This *looks* like it might be a problem in avahi_threaded_poll_*.

Comment 13 Tim Waugh 2013-07-01 14:11:59 UTC
On seconds thoughts, it is probably due to CUPS using D-Bus in its main thread -- I don't think it gets to use avahi_threaded_poll_* in that situation.

*** This bug has been marked as a duplicate of bug 979748 ***


Note You need to log in before you can comment on or make changes to this bug.