Bug 974615 - ipa client build missing dependency: python-kerberos
ipa client build missing dependency: python-kerberos
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ipa-client (Show other bugs)
5.10
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 11:41 EDT by Yi Zhang
Modified: 2013-12-08 20:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 06:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yi Zhang 2013-06-14 11:41:48 EDT
Description of problem:
yum install ipa-client on rhel5.10 nightly build failed due to missing dependency: python-kerberos 

repo:
[root@aqua (RH5.10-i386) yum.repos.d] cat rh5.10.repo
[rhel5.10.server]
name=rhel.5.10.i386.server
baseurl=http://download.lab.bos.redhat.com/nightly/latest-RHEL5.10-Server/tree-i386/Server

enabled=1
gpgcheck=0

[rhel5.10.client]
name=rhel.5.10.i386.client
baseurl=http://download.lab.bos.redhat.com/nightly/latest-RHEL5.10-Client/tree-i386/Workstation/

enabled=1
gpgcheck=0


[root@aqua (RH5.10-i386) yum.repos.d] yum install ipa-client
Loaded plugins: rhnplugin, security
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.

Error Message:
     Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
      An error has occurred while processing your request. If this problem
      persists please enter a bug report at bugzilla.redhat.com.
      If you choose to submit the bug report, please be sure to include
      details of what you were trying to do when this error occurred and
      details on how to reproduce this problem.

rhel5.10.client                       | 1.4 kB     00:00
rhel5.10.client/primary                       | 271 kB     00:00
rhel5.10.client                                      895/895
rhel5.10.server                       | 1.4 kB     00:00
rhel5.10.server/primary                       | 917 kB     00:04
rhel5.10.server                                    2540/2540
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ipa-client.i386 0:2.1.3-6.el5 set to be updated
--> Processing Dependency: python-kerberos for package: ipa-client
--> Finished Dependency Resolution
ipa-client-2.1.3-6.el5.i386 from rhel5.10.server has depsolving problems
   --> Missing Dependency: python-kerberos is needed by package
ipa-client-2.1.3-6.el5.i386 (rhel5.10.server)
Error: Missing Dependency: python-kerberos is needed by package
ipa-client-2.1.3-6.el5.i386 (rhel5.10.server)
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@aqua (RH5.10-i386) yum.repos.d]

Version-Release number of selected component (if applicable): ipa-client on rhel5.10


How reproducible: always
Comment 5 Varun Mylaraiah 2013-06-19 08:50:58 EDT
fails on ppc64 
[root@ibm-js22-vios-01-lp1 ~]# uname -a
Linux ibm-js22-vios-01-lp1.rhts.eng.bos.redhat.com 2.6.18-360.el5 #1 SMP Fri Jun 7 14:31:48 EDT 2013 ppc64 ppc64 ppc64 GNU/Linux
[root@ibm-js22-vios-01-lp1 ~]# 

[root@ibm-js22-vios-01-lp1 ~]# rpm -qa ipa-client
ipa-client-2.1.3-6.el5

[root@ibm-js22-vios-01-lp1 ~]# ipa-client-install
There was a problem importing one of the required Python modules. The
error was:

    No module named kerberos
---
and it works on ia64 and s390x
Comment 6 Rob Crittenden 2013-06-19 10:19:40 EDT
Installing the ppc package fixed this.

ppc64 apparently uses a 32-bit userspace by default, so the python was 32-bit adn didn't look in lib64 for kerberos.so.
Comment 7 Martin Kosek 2013-06-19 10:23:58 EDT
That's strange. Do we need to do anything in this case? Should some Bug for python/python-kerberos in 5.10 be filed?
Comment 8 Rob Crittenden 2013-06-19 10:32:57 EDT
I can look at the packaging guidelines to see if there should be an arch dependency on python, but I doubt there is.

This was caused by manually downloading and installing an rpm. This is definitely an edge case.
Comment 10 Martin Kosek 2013-10-07 06:17:33 EDT
Closing as CURRENTRELEASE - the issue was fixed in 5.10

Note You need to log in before you can comment on or make changes to this bug.