Bug 974616 - Nemo autostart does not work anymore
Nemo autostart does not work anymore
Status: CLOSED DUPLICATE of bug 963433
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 11:42 EDT by Bas Mevissen
Modified: 2013-06-14 14:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 14:03:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bas Mevissen 2013-06-14 11:42:49 EDT
Since the last update of my system (since some time), nemo does not autostart anymore. I tried removing all configuration files for both nemo and cinnamon, but that did not help.

$ gsettings get org.nemo.desktop show-desktop-icons
true

Running it by hand with alt-f2 and typing nemo -n works fine.

When I run 
gsettings set org.nemo.desktop show-desktop-icons false
the icons disappear

and they return when I run
gsettings set org.nemo.desktop show-desktop-icons true

cinnamon-1.9.1-12.fc19.x86_64
nemo-extensions-1.8.2-3.fc19.x86_64
nemo-open-terminal-1.0.0-4.fc19.x86_64
nemo-1.8.2-3.fc19.x86_64
nemo-devel-1.8.2-3.fc19.x86_64

An "rpm -V" of those packages does not reveal anything.

Any idea how to debug this further?
Comment 1 leigh scott 2013-06-14 12:06:46 EDT
Remove nemo-open-terminal as it's obsolete.
Do you have a nemo.desktop file in ~/.local/share/applications


Every thing is started from the session files now

http://paste.fedoraproject.org/18689/13712258


To help debug could you post ~/.xsession-errors
Comment 2 Bas Mevissen 2013-06-14 12:22:34 EDT
I removed the nemo-open-terminal package. Can you add an Obsolete: to a next version of the nemo package?

No nemo.desktop file there.

No ~/.xsession-errors file available. Strange.
Comment 3 Bas Mevissen 2013-06-14 13:00:56 EDT
This is fun...
I restored the selinux context of $HOME to see whether that caused the issue with the ~/.xsession-errors file. Even when manually creating that file, no errors are logged there.

After a reboot, Nautilus popped up to draw my desktop. So I shut that down with gnome-tweak-tool, rebooted again and now nemo seems to be working fine.
(and yes, I kept the gsettings for both the same before the reboot)

What I did do before rebooting, was removing the nemo and cinnamon settings in ~/.config, ~/.local and clearing ~/.cache and logoff/logon. That did not seem to make any difference.

I think I force a relabel, as everything should be standard from this clean install. Maybe the btrfs crash did kill something.
Comment 4 Bas Mevissen 2013-06-14 13:21:14 EDT
Relabeling done, now it sometimes starts with the desktop icons and sometimes without. I still get an sealert for /usr/libexec/accounts-daemon. Should not be of influence. Even though it is annoying.

Still nothing in ~/.xsession-errors...

Now the problem seems to be mostly happening at the first logon after boot. Any ideas?
Comment 5 leigh scott 2013-06-14 13:57:00 EDT
By adding draw icons to nautilus you are autostarting it, this is a nautilus issue not nemo.
nautilus is intruding on a cinnamon session.
Comment 6 leigh scott 2013-06-14 14:03:49 EDT

*** This bug has been marked as a duplicate of bug 963433 ***

Note You need to log in before you can comment on or make changes to this bug.