Bug 974630 - [RFE]Provide a tool to clear SPM status and initiate SPM reelection
[RFE]Provide a tool to clear SPM status and initiate SPM reelection
Status: CLOSED DUPLICATE of bug 629034
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Cathrow
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 12:45 EDT by Marina
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 12:52:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 400043 None None None Never

  None (edit)
Description Marina 2013-06-14 12:45:22 EDT
We need a tool to clear SPM status and initiate SPM reelection.

2. Who is the customer behind the request?
GSS

3. What is the nature and description of the request?
We need a tool to clear SPM status and initiate SPM reelection.

4. Why does the customer need this? (List the business requirements here)
In some cases, SPM host is lost, but the database is not cleared and it is still considered to be SPM.
So that SPM status cannot be moved to another host and the Data Center remains non-operational, till some manual cleaning is applied to the database.

5. How would the customer like to achieve this? (List the functional requirements here)
Option#1: provide a script, similar to unlock_entity.sh.
Option#2: provide a command in UI "Move SPM to another host". Since this operation might be dangerous, it would be good to have some warnings and asking customer for confirmation before proceeding. Would it require Data Center moving into maintenance first?)

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
Try and see if it works on a regular RHEV setup.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
I didn't find.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
NO. General ASAP.

9. Is the sales team involved in this request and do they have any additional input?
NO.

10. List any affected packages or components.
ovirt-engine-backup

11. Would the customer be able to assist in testing this functionality if implemented?
Yes.
Comment 2 Marina 2013-06-14 12:52:35 EDT

*** This bug has been marked as a duplicate of bug 629034 ***

Note You need to log in before you can comment on or make changes to this bug.