Bug 974646 - Duplicate Networks in Networking Tab
Duplicate Networks in Networking Tab
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: Upstream M1
: 4.0
Assigned To: Julie Pichon
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 13:28 EDT by Oved Ourfali
Modified: 2016-04-26 11:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-0.12b3.el6ost
Doc Type: Bug Fix
Doc Text:
Networks listed in the 'Launch Instance' screen were not cleared before being generated. As a result, duplicate non-functioning networks appeared on the 'Networking' tab when returning to the screen from another action. This update clears the network list before generating, and listed networks are not duplicated.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:06:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Duplicate Networks (153.22 KB, image/png)
2013-06-14 13:28 EDT, Oved Ourfali
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1170193 None None None Never

  None (edit)
Description Oved Ourfali 2013-06-14 13:28:22 EDT
Created attachment 761374 [details]
Duplicate Networks

Description of problem:

After importing an SSH key through the "Launch Instance" interface the available networks listed on the "Networking" tab are duplicated, with only one set actually functioning (clicking on the non-functional ones just causes them to move around in the list if you have more than one network).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to reproduce:

1. Launch instance creator UI from within Horizon
2. Import a keypair on the "Access & Security" tab
3. Switch to "Networking" tab 

Actual results:
Duplicate networks under available networks

Expected results:
Each network should appear once

Additional info:

See attachment with a screenshot
https://bugs.launchpad.net/horizon/+bug/1170193
Comment 2 Matthias Runge 2013-08-23 07:39:55 EDT
Fixed upstream

https://review.openstack.org/28032 for havana-1
and backported for grizzly
https://review.openstack.org/39489
Comment 5 Nir Magnezi 2013-11-26 04:23:45 EST
Verified NVR: python-django-horizon-2013.2-5.el6ost.noarch

Repeated the steps to reproduce in Comment #0
Result: Each network appear once.
Comment 8 errata-xmlrpc 2013-12-19 19:06:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.