Bug 974684 - amqp dependency
amqp dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-kombu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On: 976847
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 15:43 EDT by Eric Harney
Modified: 2013-06-24 13:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 13:07:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Harney 2013-06-14 15:43:47 EDT
Description of problem:
python-kombu's requires.txt in egg-info indicates that it depends on "amqp", but that isn't packaged for Fedora.  I'm not sure what this means for kombu's functionality, but it does appear to be used in the code.  (transport/pyamqp.py)

I noticed this because python-stevedore looks at the egg-info when loading a module.  Currently it cannot load the kombu module due to this unsatisfied requirement.

My guess is that we need to either package python-amqp, or patch it out of kombu.

Version-Release number of selected component (if applicable):
python-kombu-2.5.10-1.fc20.noarch
Comment 1 Rahul Sundaram 2013-06-14 16:10:16 EDT
Would you want to package up python-amqp from https://pypi.python.org/pypi/amqp/  It should be pretty trivial amount of work. I can help you with a review and add it as a dependency to this package later.
Comment 2 Eric Harney 2013-06-21 12:06:25 EDT
(In reply to Rahul Sundaram from comment #1)

Rahul:  I've posted a python-amqp package for review at https://bugzilla.redhat.com/show_bug.cgi?id=976847 .

Would you like to take a look at that?

Note You need to log in before you can comment on or make changes to this bug.