Bug 974704 - failed puppet uploads remain in the uploads list
failed puppet uploads remain in the uploads list
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity unspecified
: ---
: 2.4.0
Assigned To: Chris Duryee
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 17:33 EDT by Jeremy Cline
Modified: 2014-08-09 02:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-09 02:56:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Cline 2013-06-14 17:33:51 EDT
Description of problem: I created a large, fake puppet module to test pause/cancel/resume puppet uploads. This fake module failed to import successfully with the following error:

Uploading: jeremy-garbage-0.0.1.tar.gz
[==================================================] 100%
204871680/204871680 bytes
... completed

Importing into the repository...
The values for the following properties were invalid:
/var/lib/pulp/uploads/9e24ae94-ee4c-446b-b854-d274c926c143

Afterwards, this fake module was in the puppet repo uploads cancel/list/resume menus.


Version-Release number of selected component (if applicable):
pulp-server-2.2.0-0.3.beta.fc18.noarch
pulp-puppet-admin-extensions-2.2.0-0.3.beta.fc18.noarch


How reproducible: 


Steps to Reproduce:
1. dd if=/dev/urandom of=garbage.iso bs=2048 count=100000
2. tar -cvzf author-garbage-0.0.1.tar.gz garbage.iso
3. Create a repo then upload: pulp-admin puppet repo uploads upload --repo-id=upload_repo -f author-garbage-0.0.1.tar.gz

Actual results:
After repeating the upload 4 times:
[jcline@jcline ~]$ pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

[ Paused  ] jeremy-garbage-0.0.1.tar.gz
[ Paused  ] jeremy-garbage-0.0.1.tar.gz
[ Paused  ] jeremy-garbage-0.0.1.tar.gz
[ Paused  ] jeremy-garbage-0.0.1.tar.gz


Expected results:
I'm not sure if the import should succeed or not, but upon failing I would not expect to find it as a paused upload.

Additional info:
Comment 2 Barnaby Court 2014-02-18 15:41:03 EST
Tested with current master and this appears to no longer be a bug
Comment 3 Jeff Ortel 2014-04-03 09:36:03 EDT
build: 2.4.0-0.7.beta
Comment 4 Preethi Thomas 2014-04-24 14:51:04 EDT
Failing. This is still an issue.

[root@pulp-24-server ~]# pulp-admin puppet repo uploads  upload --repo-id uppload -f author-garbage-0.0.1.tar.gz  -v
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: author-garbage-0.0.1.tar.gz
... completed

Files to be uploaded:
  author-garbage-0.0.1.tar.gz

Creating upload requests on the server...
[==================================================] 100%
Initializing: author-garbage-0.0.1.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: author-garbage-0.0.1.tar.gz
[==================================================] 100%
204832642/204832642 bytes
... completed

Importing into the repository...
Import postponed due to queued operations against the repository. The progress
of this import can be viewed in the repository tasks list.

[root@pulp-24-server ~]# pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

[ Paused  ] author-garbage-0.0.1.tar.gz


[root@pulp-24-server ~]# pulp-admin puppet repo uploads  upload --repo-id uppload -f author-garbage-0.0.1.tar.gz  -v
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: author-garbage-0.0.1.tar.gz
... completed

Files to be uploaded:
  author-garbage-0.0.1.tar.gz

Creating upload requests on the server...
[==================================================] 100%
Initializing: author-garbage-0.0.1.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: author-garbage-0.0.1.tar.gz
[==================================================] 100%
204832642/204832642 bytes
... completed

Importing into the repository...
Import postponed due to queued operations against the repository. The progress
of this import can be viewed in the repository tasks list.

[root@pulp-24-server ~]# pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

[ Paused  ] author-garbage-0.0.1.tar.gz
[ Paused  ] author-garbage-0.0.1.tar.gz

[root@pulp-24-server ~]#
Comment 5 Randy Barlow 2014-05-07 10:56:24 EDT
I'm moving this back to new so anybody on the team can take a look at it.
Comment 6 Chris Duryee 2014-05-07 15:04:26 EDT
This works with 2.4.0-0.11.beta. Marking as ON_QA.

[pulpdev@localhost ~]$ pulp-admin puppet repo uploads  upload --repo-id bztest2 -f author-garbage-0.0.2.tar.gz  -v                                                           
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: author-garbage-0.0.2.tar.gz
... completed

Files to be uploaded:
  author-garbage-0.0.2.tar.gz

Creating upload requests on the server...
[==================================================] 100%
Initializing: author-garbage-0.0.2.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: author-garbage-0.0.2.tar.gz
[==================================================] 100%
204832900/204832900 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.


[/]
Running...

Task Succeeded


Deleting the upload request...
... completed

[pulpdev@localhost ~]$ pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

No outstanding uploads found
Comment 7 Preethi Thomas 2014-06-03 13:20:41 EDT
verified
[root@ibm-x3550m3-08 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.19.beta.el6.noarch
[root@ibm-x3550m3-08 ~]# 

[root@ibm-x3550m3-08 ~]# pulp-admin puppet repo create --repo-id upload_repo
Successfully created repository [upload_repo]

[root@ibm-x3550m3-08 ~]# pulp-admin puppet repo uploads upload --repo-id=upload_repo -f author-garbage-0.0.1.tar.gz -v
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: author-garbage-0.0.1.tar.gz
... completed

Files to be uploaded:
  author-garbage-0.0.1.tar.gz

Creating upload requests on the server...
[==================================================] 100%
Initializing: author-garbage-0.0.1.tar.gz
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: author-garbage-0.0.1.tar.gz
[=====================                             ] 42%
87031808/204833101 bytes
^CUploading paused

[root@ibm-x3550m3-08 ~]# pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

[ Paused  ] author-garbage-0.0.1.tar.gz

[root@ibm-x3550m3-08 ~]# 
[root@ibm-x3550m3-08 ~]# 
[root@ibm-x3550m3-08 ~]# pulp-admin puppet repo uploads resume
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

Select one or more uploads to resume: 
  -  1 : author-garbage-0.0.1.tar.gz
Enter value (1-1) to toggle selection, 'c' to confirm selections, or '?' for
more commands: 1

Select one or more uploads to resume: 
  x  1 : author-garbage-0.0.1.tar.gz
Enter value (1-1) to toggle selection, 'c' to confirm selections, or '?' for
more commands: c

Resuming upload for: author-garbage-0.0.1.tar.gz

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: author-garbage-0.0.1.tar.gz
[==================================================] 100%
204833101/204833101 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.


[-]
Running...

Task Succeeded


Deleting the upload request...
... completed

[root@ibm-x3550m3-08 ~]# pulp-admin puppet repo uploads list
+----------------------------------------------------------------------+
                            Upload Requests
+----------------------------------------------------------------------+

No outstanding uploads found

[root@ibm-x3550m3-08 ~]#
Comment 8 Randy Barlow 2014-08-09 02:56:32 EDT
This has been fixed in Pulp 2.4.0-1.

Note You need to log in before you can comment on or make changes to this bug.