Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974735 - Cannot start ibus input method
Summary: Cannot start ibus input method
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 974788 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-15 04:43 UTC by Qiao
Modified: 2013-06-21 02:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-21 02:11:16 UTC
Type: Bug


Attachments (Terms of Use)
Error info screen capture (238.44 KB, image/png)
2013-06-15 04:43 UTC, Qiao
no flags Details
~/.cache/imsettings/log (5.00 KB, text/plain)
2013-06-15 04:46 UTC, Qiao
no flags Details

Description Qiao 2013-06-15 04:43:50 UTC
Created attachment 761501 [details]
Error info screen capture

Description of problem:
When I upgrade from 18 to 19, ibus input method can't start again.


Version-Release number of selected component (if applicable):
ibus-chewing-1.4.3-3.fc19.x86_64
ibus-gtk2-1.5.2-5.fc19.x86_64
ibus-libpinyin-1.6.91-1.fc19.x86_64
libuser-python-0.59-1.fc19.x86_64
ibus-gtk3-1.5.2-5.fc19.x86_64
libuser-0.59-1.fc19.x86_64
libusbx-1.0.15-2.fc19.x86_64
ibus-rawcode-1.3.2-1.fc19.x86_64
ibus-hangul-1.4.2-4.fc19.x86_64
libusb-0.1.4-1.fc19.i686
ibus-libs-1.5.2-5.fc19.x86_64
ibus-typing-booster-0.0.32-1.fc19.noarch
ibus-1.5.2-5.fc19.x86_64
ibus-anthy-1.5.3-1.fc19.x86_64
libusb-0.1.4-1.fc19.x86_64
ibus-m17n-1.3.4-10.fc19.x86_64
ibus-qt-1.3.2-2.fc19.x86_64

How reproducible:
Open im-chooser, select ibus

Actual results:
report this error:
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by IMSettings.

Comment 1 Qiao 2013-06-15 04:46:49 UTC
Created attachment 761510 [details]
~/.cache/imsettings/log

~/.cache/imsettings/log

Comment 2 fujiwara 2013-06-17 06:07:16 UTC
*** Bug 974788 has been marked as a duplicate of this bug. ***

Comment 3 fujiwara 2013-06-17 06:11:08 UTC
ibus 1.5.2-5 removed the dependencies of ibus-panel and ibus-setup due to the size of dvd iso in bug 972328 since GNOME does not require ibus-panel and ibus-setup.

You can run 'yum install ibus-panel' to fix your problem at the moment.

Now we reopen bug 972328 for f19.

Comment 4 Qiao 2013-06-17 06:44:07 UTC
Resolved my probolem use this method.
(In reply to fujiwara from comment #3)
> ibus 1.5.2-5 removed the dependencies of ibus-panel and ibus-setup due to
> the size of dvd iso in bug 972328 since GNOME does not require ibus-panel
> and ibus-setup.
> 
> You can run 'yum install ibus-panel' to fix your problem at the moment.
> 
> Now we reopen bug 972328 for f19.

Comment 5 fujiwara 2013-06-21 02:11:16 UTC
Fixed bug 972328.


Note You need to log in before you can comment on or make changes to this bug.