This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 974743 - Group named german-support missing
Group named german-support missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 05:06 EDT by Simon Lewis
Modified: 2014-02-04 22:42 EST (History)
5 users (show)

See Also:
Fixed In Version: system-config-language-1.4.0-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-18 23:01:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Lewis 2013-06-15 05:06:08 EDT
When applying German in system-config-language dialogue following error message is obtaimed:

"No Group named german-support exists: Do you still want to install language without proper support?"


Steps to reproduce this:

Fedora 19 beta installed from KDE-live iso with German language selected in Anaconda...

- German keyboard / local settings / some but not all translations 
   were installed and / or configured. 

- KDE 4 German internationalisation was not installed.

Subsequently installed system-config-language.noarch 

Run system-config-language.noarch from terminal select and apply German language.

Terminal output:

# system-config-language
Geladene Plugins: langpacks, refresh-packagekit
Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 179, in okClicked
    self.apply()
  File "/usr/share/system-config-language/language_gui.py", line 269, in apply
    if not install.is_group_installed(grpid, self.mainWindow):
  File "/usr/share/system-config-language/gui_install.py", line 118, in is_group_installed
    raise yum.Errors.GroupsError, "No Group named %s exists" % grpid
yum.Errors.GroupsError: No Group named german-support exists
#
Comment 1 Parag Nemade 2013-06-15 10:47:19 EDT
system-config-language is broken currently. If you want to install German support alternative way is to use following command
sudo yum langinstall de
Comment 2 Parag Nemade 2013-12-16 12:11:17 EST
Currently yum groups behaviour is broken in Fedora 20 due to removed language support groups and yum started using groups as objects now. The better solution can be provided is to stop reporting this as a error and have some more meaningful informative message like "Due to comps cleanup %s group got removed and no longer exists. Therefore only setting the default system language".
Comment 3 Parag Nemade 2014-01-15 23:36:42 EST
Fixed in system-config-language-1.4.0-7.fc20 build on koji.
Comment 4 Fedora Update System 2014-01-15 23:39:02 EST
system-config-language-1.4.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-7.fc20
Comment 5 Fedora Update System 2014-01-16 00:10:04 EST
system-config-language-1.4.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-7.fc19
Comment 6 Fedora Update System 2014-01-17 00:42:03 EST
Package system-config-language-1.4.0-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-language-1.4.0-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0976/system-config-language-1.4.0-7.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-01-18 23:01:36 EST
system-config-language-1.4.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2014-01-27 01:27:04 EST
system-config-language-1.4.0-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/system-config-language-1.4.0-8.fc19
Comment 9 Fedora Update System 2014-02-04 22:42:05 EST
system-config-language-1.4.0-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.