Bug 974754 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:68b6b8194f7ef8e2df27739ed45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 08:48 EDT by perani.s92
Modified: 2013-06-18 20:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 20:33:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description perani.s92 2013-06-15 08:48:05 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 18.37.11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1189, in destroyDevice
    if device.format.exists and device.format.type:
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 859, in removeEmptyExtendedPartitions
    self.destroyDevice(extended)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 799, in clearPartitions
    self.removeEmptyExtendedPartitions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 445, in execute
    storage.clearPartitions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1480, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 399, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'format'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=/ubninit root=live:UUID=4C6A-D724 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/ubnkern 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.i686
other involved packages: python-libs-2.7.3-13.fc18.i686
package:        anaconda-18.37.11-1.fc18.i686
packaging.log:  
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Brian Lane 2013-06-18 20:33:33 EDT
Things have changed quite a bit since F18, but thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.