Bug 974763 - Hotplug of ExpressCard not working
Hotplug of ExpressCard not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 11:41 EDT by Rutger Noot
Modified: 2014-05-23 13:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 08:37:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci (1.73 KB, text/plain)
2013-06-15 11:41 EDT, Rutger Noot
no flags Details
output of lspci when booted with usb card inserted (1.82 KB, text/plain)
2013-06-15 11:43 EDT, Rutger Noot
no flags Details
output of dmesg after plugging usb 3.0 expresscard (66.93 KB, text/plain)
2013-07-01 14:45 EDT, Rutger Noot
no flags Details

  None (edit)
Description Rutger Noot 2013-06-15 11:41:55 EDT
Created attachment 761603 [details]
output of lspci

Description of problem: I have an USB 3.0 ExpressCard. Hotplugging the card on my (2 year old DELL) laptop does not work. 


Version-Release number of selected component (if applicable): kernel 3.9.5-201.fc18


How reproducible:


Steps to Reproduce:
1. Plug in the ExpressCard
2.
3.

Actual results: Nothing


Expected results: Card shows up in lspci and attached usb-devices in lsusb


Additional info:
I tries the following 
1. Enable pciehp_force
2. Enable pciehp_poll_mode
3. Set pciehp_poll_time
4. Load the modules shpchp or acpiphp_ibm
5. Combinations of 1-5

On the other hand, if the card is present on boot, it gets detected, configured and it works!
Comment 1 Rutger Noot 2013-06-15 11:43:08 EDT
Created attachment 761604 [details]
output of lspci when booted with usb card inserted
Comment 2 Josh Boyer 2013-07-01 14:06:31 EDT
Can you attach the output of dmesg after you hotplug the card?
Comment 3 Rutger Noot 2013-07-01 14:45:48 EDT
Created attachment 767473 [details]
output of dmesg after plugging usb 3.0 expresscard

Inserting the card add 2 last lines to dmesg, but nothing else. No difference if pciehp_force is set or not.
Comment 4 Rutger Noot 2013-10-06 09:49:55 EDT
Hotplug of this card works under kernel-3.10.12-100.fc18.x86_64
As far as I am concerned this one is solved.
Comment 5 Josh Boyer 2013-10-07 08:37:04 EDT
Thanks for letting us know.
Comment 6 Rutger Noot 2014-05-23 13:44:54 EDT
This problem came back in Fedora 20, now running kernel-3.14.4-200.fc20.x86_64

Usually the card stays in the computer permanently so I don't know exactly since when hotplugging is broken again. 

I tried setting pciehp_force and pciehp_poll_mode to no avail

Note You need to log in before you can comment on or make changes to this bug.