Bug 974773 - rpm and yum are warning about the mingw32_c and _mingw32_c macros
rpm and yum are warning about the mingw32_c and _mingw32_c macros
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mingw-filesystem (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik van Pienbroek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 13:09 EDT by Bruno Wolff III
Modified: 2013-06-17 00:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: mingw-filesystem-99-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 00:28:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2013-06-15 13:09:23 EDT
Description of problem:
Whenever I run rpm or yum I get the following warnings:
warning: Macro %mingw32_c needs whitespace before body
warning: Macro %mingw32_c needs whitespace before body
warning: Macro %_mingw32_c needs whitespace before body
warning: Macro %_mingw32_c needs whitespace before body


Version-Release number of selected component (if applicable):
mingw32-filesystem-98-2.fc20.noarch
rpm-4.11.1-0.rc1.3.fc20.i686
Comment 1 Richard W.M. Jones 2013-06-15 13:17:00 EDT
The explanation for this warning is here:

https://lists.fedoraproject.org/pipermail/devel/2013-June/183886.html

If we look at the macros in mingw32-filesystem then
we can see:

%mingw32_c++             %{mingw32_target}-c++
%mingw32_c++filt         %{mingw32_target}-c++filt
[..]
%_mingw32_c++                  %{mingw32_c++}
%_mingw32_c++filt              %{mingw32_c++filt}

These are bogus.  It looks like %mingw32_c++ and %_mingw32_c++
should simply be deleted, and check there are no spec files that
are trying to use these (they wouldn't work so it seems unlikely).

The other two should be replaced with:

%mingw32_cxxfilt         %{mingw32_target}-cxxfilt
%_mingw32_cxxfilt              %{mingw32_cxxfilt}
Comment 2 Erik van Pienbroek 2013-06-15 14:12:35 EDT
This was already spotted by Kalev Lember and reported on IRC. He also fixed it already in mingw-filesystem-99 which will be pushed to f19 later today
Comment 3 Fedora Update System 2013-06-15 20:33:38 EDT
mingw-filesystem-99-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mingw-filesystem-99-1.fc19
Comment 4 Fedora Update System 2013-06-17 00:28:59 EDT
mingw-filesystem-99-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.