Bug 974795 - Position of Navigation Buttons (Continue, Done, Begin installation) appears inconsistent
Position of Navigation Buttons (Continue, Done, Begin installation) appears i...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 18:00 EDT by Matthias Petermann
Modified: 2013-06-18 20:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 20:29:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Petermann 2013-06-15 18:00:42 EDT
Hello,

first of all: I am not a regular Fedora user and just take a look at it
from time to time, because it is the most up-to-date Linux distribution
available in a handy package. Anyway, you ear much respect for doing a
really great job, making the bleeding edge of Open Source manageable for
the end users. Withou you, I would not be irresolute whether to stay 
with Gnome 3.4 on my regular distro or try Fedora for some months and
get 3.8 because it looks so nice ;-)

Anyway, there was one minor thing I found a bit confusing in the Anaconda
installer. It's not a bug but a UI design thing.

Most people read UI screens like a book - from top left to bottom right.
In the top row you get summary information. In the middle row you get
details and are allowed to apply changes, and in the bottom row you 
make a final decision. While left and right reading direction may 
differ depending on locale, the top to bottom is always valid.
The Anaconda installer follows this proven pattern for the first
UI screen (Language Selection - Continue button bottom right) and 
also for the Installation summary main page (Begin installation button
bottom right).

Surprisingly, this pattern is twisting through most of the rest of the
installation process UI screens. Their Continue/Done/etc. Buttons are
now top left, where a usual desktop user would not expect them.

For a dispassionate user, this might appears a bit inconsistent. 

Is there some special purpose in placing the decision buttons on top?

Kind regards,
Matthias
Comment 1 Brian Lane 2013-06-18 20:29:05 EDT
It was designed this way on purpose. Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.