Bug 97481 - Crash when reading CGI generated kickstart files
Summary: Crash when reading CGI generated kickstart files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-16 15:15 UTC by Travis Crawford
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 21:57:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash output (662 bytes, text/plain)
2003-06-16 15:17 UTC, Travis Crawford
no flags Details
Script output (the ks file) (135 bytes, text/plain)
2003-06-16 15:19 UTC, Travis Crawford
no flags Details
Script (1009 bytes, text/plain)
2003-06-16 15:20 UTC, Travis Crawford
no flags Details

Description Travis Crawford 2003-06-16 15:15:46 UTC
Description of problem:
Crash when reading CGI generated kickstart files. Might have something to do
with handling of the content-type line.


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1. Write a CGI script that outputs a Kickstart file.
2. Pass ks=http://web_server/script.cgi to the kernel.
3. Watch as the installer crashes.


Actual results:
Anaconda crashes.


Expected results:
Automated install.


Additional info:
A text file (created by wget'ting the script works as expected (the install
works.) When the CGI script is the specified kickstart file anaconda crashes.

Comment 1 Travis Crawford 2003-06-16 15:17:48 UTC
Created attachment 92428 [details]
Crash output

Comment 2 Travis Crawford 2003-06-16 15:19:20 UTC
Created attachment 92429 [details]
Script output (the ks file)

Comment 3 Travis Crawford 2003-06-16 15:20:54 UTC
Created attachment 92430 [details]
Script

Comment 4 Jeremy Katz 2003-06-16 16:21:39 UTC
Your web server is created chunked output which our simplistic http client can't
handle.  You need to configure your web server to not return chunked output.

Newer versions handle this better.

Comment 5 Travis Crawford 2003-06-16 19:50:10 UTC
Thanks for the chunking info. Since chunking is a HTTP/1.1 feature, adding a few
lines to httpd.conf fixed the problem.

SetEnv nokeepalive
SetEnv downgrade-1.0
SetEnv force-response-1.0

Perhaps Anaconda could default to making HTTP/1.0 requests? Or are there any
HTTP/1.1 features that make sticking with the new version better?

Comment 6 Jeremy Katz 2003-06-19 21:57:58 UTC
More current releases only request 1.0


Note You need to log in before you can comment on or make changes to this bug.