Bug 974871 - fsadm will not perform online resize when -v is set
fsadm will not perform online resize when -v is set
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-16 16:55 EDT by Wilbur Smith
Modified: 2013-10-10 08:57 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 08:57:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wilbur Smith 2013-06-16 16:55:02 EDT
Description of problem:

When using fsadm -verbose to resize a newly extented LVM2 partition, an error message is displayed saying mounted / partitions can not be expamned while online. If -v is removed, online resize works correctly

Version-Release number of selected component (if applicable):

Kernel 2.6.32-358.111.1.openstack.el6.x86_64
LVM TOOLS 2.02.98(2)-RHEL6 (2012-10-15)

How reproducible:


Steps to Reproduce:
1. Use lvextend to add more space to an exsisting lvm2 partition
2. Attempt to run fsadm /dev/sda1/home -v  to extend partition
3. Error prints saying / mounted partitions can be extended while mounted

Actual results:

Volume would expand while online, but with virbose information on process

Expected results:

error is shown until -v is removed

Additional info:
Comment 2 Alasdair Kergon 2013-06-16 21:25:44 EDT
For reference, please would you paste into the bugzilla a transcript showing the two cases, the one that works and the identical one apart from -v that fails?
Comment 3 Alasdair Kergon 2013-06-16 21:30:08 EDT
- What filesystem type?

- Have you tried lvextend --resizefs?

- What happens if you use '--verbose' instead of the '-verbose' you say you used?
Comment 4 Wilbur Smith 2013-06-20 18:16:06 EDT
This is on an ext4 filesystem using LVM2. When I originally observed this, I tried both:
 fsadm resize /dev/vg_redshirt/lv_root 
               and 
fsadm resize /dev/vg_redshirt/lv_root 2048

Only by using the absolute number of blocks to expand was I able to get things to work.

I tried to recreate today can capture the output, but it is now working correctly for both use cases. When I originally tried to run this, my /root had 0 bytes of free space. After freeing up space, this command seems to work as expected.

Since this seems to be tied to a diskspace issue vs fsadm, I recomend we close this bug.
Comment 5 Zdenek Kabelac 2013-06-21 04:32:29 EDT
There could a problem with reporting errors when filesystem is full - since then code path depend on your settings of temporary directory.

Note You need to log in before you can comment on or make changes to this bug.