Bug 974873 - rfe: sysctl flag to reset option to default
rfe: sysctl flag to reset option to default
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-16 17:24 EDT by James Patterson
Modified: 2013-09-16 08:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 08:49:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Patterson 2013-06-16 17:24:44 EDT
Description of problem:
It would be useful to have an option for sysctl to list or set the
default value for a given key.

I've asked upstream if they could implement this, but they can't until they have a way of asking the kernel what the default was.

Should I move this to component kernel, or is there a better place to request this?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaromír Cápík 2013-06-19 08:42:16 EDT
Hello James.

I'm one of the upstream members and I've read your message sent to the upstream mailing list. This is definitely a feature request for kernel. It needs to support a way of obtaining the default values. Like Craig has said, hardcoding the values somewhere or providing a file holding a table of default values is absolutely unreal, since the default values can be different for each kernel and can depend on the kernel configuration.

I'm changing the component to kernel and let's see what happens.

Regards,
Jaromir.
Comment 2 Josh Boyer 2013-09-16 08:49:22 EDT
You should probably make an RFE on the upstream kernel mailing list.

Note You need to log in before you can comment on or make changes to this bug.