Bug 974903 - Fail to install rubygem-openshift-origin-common on broker due to dependency issue
Fail to install rubygem-openshift-origin-common on broker due to dependency i...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 01:52 EDT by Gaoyun Pei
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 11:45:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2013-06-17 01:52:08 EDT
Description of problem:
While installing broker packages, rubygem-openshift-origin-common.noarch was unable to be installed due to missing dependency: ruby193-rubygem-safe_yaml


Version-Release number of selected component (if applicable):
puddle-1-2-2013-06-17-RC1
http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-06-14.15/

How reproducible:
Always

Steps to Reproduce:
1. Set up an OSE env using the installation script, it would be aborted when installing broker packages 
...
---> Package rubygem-openshift-origin-common.noarch 0:1.8.9-1.1.el6op will be installed
--> Processing Dependency: ruby193-rubygem(safe_yaml) for package: rubygem-openshift-origin-common-1.8.9-1.1.el6op.noarch
--> Finished Dependency Resolution
Error: Package: rubygem-openshift-origin-common-1.8.9-1.1.el6op.noarch (openshift_infrastructure)
           Requires: ruby193-rubygem(safe_yaml)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
yum install failed; aborting installation. Please ensure you have configured the relevant repos/subscriptions.


Actual results:


Expected results:
All the packages should be installed successfully

Additional info:
BTW, the ruby193-rubygem-safe_yaml packages could be found in openshift-node.repo
Comment 2 Brenton Leanhardt 2013-06-17 02:34:41 EDT
Good catch.  Luke actually already reported this but and I just realized why my smoke test didn't catch it.  I was testing in an all-in-one environment and that package does exist in the Node repository.
Comment 4 Gaoyun Pei 2013-06-18 05:46:56 EDT
Verify this on puddle: 
http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-06-17.3/

The installation was successful without dependency issue
Comment 5 Luke Meyer 2013-06-28 11:45:54 EDT
Closing all bugs introduced, fixed, and verified during 1.2 release work (thus never shipped).

Note You need to log in before you can comment on or make changes to this bug.