Bug 97495 - UDCT Creation fails on oracle
UDCT Creation fails on oracle
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
high Severity high
: ---
: ---
Assigned To: Rafael H. Schloming
Jon Orris
:
Depends On:
Blocks: rc0blockers
  Show dependency treegraph
 
Reported: 2003-06-16 14:25 EDT by Jon Orris
Modified: 2014-12-01 18:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 14:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-06-16 14:25:48 EDT
Description of problem:
@32440

Creating a User Defined Content Type fails under oracle.

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
goodeats.boston.redhat.com:8080:52ecc71b:f5d1da7f7b -*-*-*-
-*-*-*- Message: ORA-00911: invalid character

SQL for ADD: create table fdsa (
    item_id INTEGER
        constraint fdsa_item_id_p_ffbfD
          primary key
        constraint fdsa_item_id_f_n4Lzu
          references cms_pages(item_id)
);
PDL: model com.arsdigita.cms;
object type fdsa extends com.arsdigita.cms.ContentPage {

    reference key (fdsa.item_id);
} (root cause: ORA-00911: invalid character
) -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate,compress;q=0.9
Accept-Language: en-us,en;q=0.5
Connection: close
Content-Length: 456
Content-Type: application/x-www-form-urlencoded
Cookie: JSESSIONID=aYs5hoA6yxc8;
ad_user_login=23!1150395620578!nS76KI92Eo2sTIyKCQdCKg==
Host: goodeats.boston.redhat.com:8080
Referer:
http://goodeats.boston.redhat.com:8080/ccm/articles/admin/index.jsp?bbp.68.ps=20&bbp.875.d=asc&bbp.758.d=asc&bbp.746.d=asc&bbp.s=999&bbp.i=13f2vny751u533m4xqx1hqdbkziod5k13olvjjg4cxp95n36bn6huaz8zncqm4mzjnok0kc58afpkdgn5u1ym216iff9gl3arp9c8z6ri1c3wmtw1mhrbj3v3yjmf7xmfw0w1oniw7i8z5ahh97i7v4di09dkkhz2r2ls&bbp.3.pane=6&bbp.4.folder=118&g11n.enc=UTF-8
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: aYs5hoA6yxc8 (expires: -1)
ad_user_login: 23!1150395620578!nS76KI92Eo2sTIyKCQdCKg== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.PersistenceException: ORA-00911: invalid character

SQL for ADD: create table fdsa (
    item_id INTEGER
        constraint fdsa_item_id_p_ffbfD
          primary key
        constraint fdsa_item_id_f_n4Lzu
          references cms_pages(item_id)
);
PDL: model com.arsdigita.cms;
object type fdsa extends com.arsdigita.cms.ContentPage {

    reference key (fdsa.item_id);
} (root cause: java.sql.SQLException: ORA-00911: invalid character
)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:128)
	at com.arsdigita.metadata.DynamicObjectType.save(DynamicObjectType.java:731)
	at com.arsdigita.cms.ui.type.CreateType.process(CreateType.java:264)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:449)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:423)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:267)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:275)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:148)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)
Root cause: 
java.sql.SQLException: ORA-00911: invalid character

	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.oci8.OCIDBAccess.check_error(OCIDBAccess.java(Compiled Code))
	at oracle.jdbc.oci8.OCIDBAccess.executeFetch(OCIDBAccess.java(Compiled Code))
	at oracle.jdbc.oci8.OCIDBAccess.parseExecuteFetch(OCIDBAccess.java(Compiled Code))
	at
oracle.jdbc.driver.OracleStatement.executeNonQuery(OracleStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OracleStatement.doExecuteOther(OracleStatement.java(Compiled
Code))
	at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java(Compiled
Code))
	at oracle.jdbc.driver.OracleStatement.executeUpdate(OracleStatement.java:796)
	at com.arsdigita.db.Statement.doExecuteUpdate(Statement.java:468)
	at com.arsdigita.db.Statement.executeUpdate(Statement.java:446)
	at com.arsdigita.metadata.DynamicObjectType.save(DynamicObjectType.java:728)
	at com.arsdigita.cms.ui.type.CreateType.process(CreateType.java:264)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:449)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:423)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:267)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:275)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:148)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)

Note You need to log in before you can comment on or make changes to this bug.