This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 974961 - CLI user update default org and env have no effect
CLI user update default org and env have no effect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Corey Welton
: Regression, Triaged
Depends On: 980523
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 05:16 EDT by Ales Dujicek
Modified: 2014-04-24 13:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-06-17 05:16:43 EDT
Description of problem:

command
user update --default_organization <org> --default_environment <env>
does not change user info

Version-Release number of selected component (if applicable):
katello-selinux-1.4.3-3.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-configure-1.4.3-16.el6sat.noarch
signo-katello-0.0.18-1.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
katello-common-1.4.2-14.el6sat.noarch
katello-1.4.2-14.el6sat.noarch
katello-foreman-all-1.4.2-14.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
katello-all-1.4.2-14.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-5.el6sat.noarch
katello-glue-candlepin-1.4.2-14.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch

How reproducible:
always

Steps to Reproduce:
1. user create --username bob --password testing --email e@m
Successfully created user [ bob ]
2. user update --username bob --default_organization ACME_Corporation --default_environment Library
Successfully updated user [ bob ]
3. user info --username bob

Actual results:
Default Organization : None
Default Environment  : None

Expected results:
Default Organization : ACME_Corporation
Default Environment  : Library
Comment 1 RHEL Product and Program Management 2013-06-17 05:23:02 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Og Maciel 2013-06-17 08:24:47 EDT
Added Regression keyword
Comment 5 Tom McKay 2013-07-03 17:27:19 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 4861578f8fc776b8cf0da295fad12f44925459a2
      https://github.com/Katello/katello/commit/4861578f8fc776b8cf0da295fad12f44925459a2
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-03 (Wed, 03 Jul 2013)


Branch: refs/heads/master
  Home:   https://github.com/Katello/katello-cli
  Commit: fb524b44149290adbf159b316a707c7e48383e63
      https://github.com/Katello/katello-cli/commit/fb524b44149290adbf159b316a707c7e48383e63
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-03 (Wed, 03 Jul 2013)
Comment 7 Corey Welton 2013-09-19 16:03:52 EDT
QA Verified in Satellite-6.0.2-RHEL-6-20130919.0
Comment 10 Bryan Kearney 2014-04-24 13:10:28 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 11 Bryan Kearney 2014-04-24 13:11:41 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.