Bug 974968 - a4j:push seems to not work in Showcase (Bug in PortletBridge)
a4j:push seems to not work in Showcase (Bug in PortletBridge)
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: PortletBridge (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity unspecified
: ER02
: 6.1.0
Assigned To: Ken Finnigan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 05:32 EDT by Petr Mensik
Modified: 2015-07-19 21:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The PortletBridge extension code for RichFaces was modifying how the Push process worked on the server, which caused the a4j:push component to work incorrectly. The fix removes the PortletBridge extension to RichFaces for Push. a4j:push now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 09:24:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PBR-515 Major Closed Unable to start Atmosphere in portlet 2015-06-03 06:43:09 EDT

  None (edit)
Description Petr Mensik 2013-06-17 05:32:58 EDT
There are currently two examples of a4j:push in the Showcase. Topics Context Usage example is not refreshing it's UUID by the Web Socket connection and the CDI Push doesn't work at all, the java.lang.IllegalArgumentException: pushTopic request parameter must be present is thrown. The same exception occurs if you try to refresh the Topics Context Usage page. 

Steps to reproduce

1. Deploy Showcase to JPP
2. Go to a4j:push under Ajax Action
Comment 1 Ken Finnigan 2013-06-18 16:09:29 EDT
Fixed as part of https://issues.jboss.org/browse/PBR-515 and released in PBR 3.2.1.Final, which is now used by GateIn master
Comment 2 Petr Mensik 2013-06-19 05:12:15 EDT
Yes, it's working in GateIn master with new PBR version. But I suppose we should wait to close this until it's verified in ER02.
Comment 3 Ken Finnigan 2013-06-19 09:31:41 EDT
Petr, this BZ is still open. It's only the PBR issue that is closed
Comment 5 JBoss JIRA Server 2013-08-16 14:34:48 EDT
Ken Finnigan <ken@kenfinnigan.me> updated the status of jira PBR-515 to Closed
Comment 6 Petr Mensik 2013-08-22 10:19:50 EDT
It seems to this issue is back with ER04 build. Both Topics Context Usage and CDI push doesn't work, however no exceptions are thrown and server log is empty.
Comment 7 Ken Finnigan 2013-08-26 16:05:01 EDT
This is now a different issue.

It appears the classpath/modules available between EAP 6.1.0 and latest EAP 6.1.1 have changed, causing a ClassNotFoundException when running the a4j:push example of the showcase.

In JPP, failed network requests can be seen in the developer console of the browser. Attempting to issue one of those failed requests directly in the browser shows the ClassNotFoundException.

Issue has been raised with RichFaces: https://issues.jboss.org/browse/RF-13154.

Not sure whether this problem should be tracked with this issue or a new BZ created?
Comment 8 Thomas Heute 2013-08-27 04:31:32 EDT
Petr, can you open a new BZ to follow the fixes independently ?

Looks like the first issue is fixed by a new version of PBR, while the second issue will require a new version of RF.

I am putting this one back as VERIFIED and will slightly change the title.

Note You need to log in before you can comment on or make changes to this bug.