Bug 974978 - RDO requires gender selection for account sign up
RDO requires gender selection for account sign up
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dave Neary
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 06:05 EDT by Stephen Benjamin
Modified: 2016-04-26 18:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 06:44:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Benjamin 2013-06-17 06:05:40 EDT
Description of problem:

Signing up for an account on openstack.redhat.com requires gender selection

Version-Release number of selected component (if applicable):

N/A

How reproducible:

Always

Steps to Reproduce:
1. Attempt to sign up for an account
2. Get asked for gender

Actual results:

Gender is required, and not inclusive

Expected results:

- Don't ask for Gender (why is it needed?)

- Or Gender selection is inclusive

http://itspronouncedmetrosexual.com/2012/06/how-can-i-make-the-gender-question-on-an-application-form-more-inclusive/

Additional info:

See "Why does RDO care about my gender?" on memo-list
Comment 3 Dave Neary 2013-06-17 10:17:05 EDT
Reposting comment from mailing list thread:

We don't care about your gender.

We are using the upstream version of Vanilla, which includes this
question by default. This explains why it's there. I'm happy to remove
it - IIRC, there is even a ticket against that internally. The reality
is that it was not a priority for the release, and we have not had a lot
of time since then for issues such as this, which are prioritised below
issues related to the user experience of people downloading and using RDO.

The reason Vanilla asks the questions is to use the correct gender in
some strings in the program  ("he/she", "his/her") and to use the right
gender suffix in localised versions where that's important.

I have a patch to add "Unspecified" as an option, but we'll test that in staging before pushing it live.
Comment 4 Stephen Benjamin 2013-06-17 10:34:25 EDT
Cool, thanks. Can you set the default on the sign up page to unspecified and then just hide the form? Unspecified isn't much of an improvement, calling it "Other" is better if you must ask (this is Google's solution)

Don't meant to come off as being super pedantic, I just know people who these kinds of details do matter to them.
Comment 5 Dave Neary 2013-06-18 03:53:15 EDT
There will be repercussions - extra strings that will need translating, "they" and "their" instead of "him/her/his/her", but I guess we can live with those.

Will report back when we test & push live.

Dave.
Comment 6 Dave Neary 2013-06-25 06:44:44 EDT
This went live Sunday evening. Appears to be working. There was a hidden database change needed because of the extra member of the Gender enum - "update table GDN_User change column Gender Gender enum ('m', 'f', 'o') default 'o'" - and upstream appears to have moved to this kind of scheme in the latest devel branch, so there's no point proposing this as a patch to the stable branch.

Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.