Bug 974994 - No firendly prompting message after git push 2G file failed
No firendly prompting message after git push 2G file failed
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 06:34 EDT by Lei Zhang
Modified: 2015-05-14 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 11:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lei Zhang 2013-06-17 06:34:37 EDT
Description of problem:
git push one 2G file, the output should contain "fail due to exceeding the quota".

Version-Release number of selected component (if applicable):
devenv_3368
rhc-1.10.1 build from devenv_3368

How reproducible:
always

Steps to Reproduce:
1. rhc app create -a app1 -t php-5.3
2. cd app1&&dd if=/dev/zero of=test.tmp bs=1M count=2000
3. git add -A && git commit -amp && git push

Actual results:
No firendly prompting message after git push file failed 

Expected results:
The output should contain "fail due to exceeding the quota" prompting message. 

Additional info:
Failed log
error: unpack-objects died of signal 9
error: unpack failed: unpack-objects abnormal exit
To ssh://e8d74fecd72911e2bde912313d23a556@myphp-rayzhang.dev.rhcloud.com/~/git/myphp.git/
 ! [remote rejected] master -> master (n/a (unpacker error))
error: failed to push some refs to 'ssh://e8d74fecd72911e2bde912313d23a556@myphp-rayzhang.dev.rhcloud.com/~/git/myphp.git/'
Comment 1 Jhon Honce 2013-08-15 11:11:26 EDT
At the point in the workflow this fails, we cannot provide a better message.  If the user ssh'es into the gear they will be provided a message about exceeding their quota.

Note You need to log in before you can comment on or make changes to this bug.