Bug 974996 - If EFI partition exists anaconda try to install despite EFI partition is not set for current installation
If EFI partition exists anaconda try to install despite EFI partition is not ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Brian Lane
Release Test Team
abrt_hash:8336eb28f01dd4827a35ef2ab1a...
:
Depends On: 1083985
Blocks: 972747
  Show dependency treegraph
 
Reported: 2013-06-17 06:37 EDT by Petr Janda
Modified: 2014-10-14 02:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.219-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb-wpAmTh (571.23 KB, text/plain)
2013-06-17 07:09 EDT, Petr Janda
no flags Details
untested patch (713 bytes, patch)
2014-06-04 13:40 EDT, Brian Lane
no flags Details | Diff
traceback - anaconda-13.21.220 (598.98 KB, text/plain)
2014-06-16 07:46 EDT, Petr Janda
no flags Details

  None (edit)
Description Petr Janda 2013-06-17 06:37:56 EDT
Version-Release number of selected component:
anaconda-13.21.195

Additional info:
libreport version: 2.0.9
cmdline:        /usr/bin/python  /usr/bin/anaconda
kernel:         2.6.32-381.el6.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.195 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/booty/bootloaderInfo.py", line 683, in addNewEfiEntry
:    log.error("No partition for bootdev '%s'" % (bootdev,))
:  File "/usr/lib/anaconda/booty/bootloaderInfo.py", line 754, in installGrub
:    return self.addNewEfiEntry(instRoot)
:  File "/usr/lib/anaconda/booty/x86.py", line 127, in installGrub
:    grubPath, cfPath)
:  File "/usr/lib/anaconda/booty/x86.py", line 238, in writeGrub
:    ret = self.installGrub(instRoot, bootDev, grubTarget, grubPath, cfPath)
:  File "/usr/lib/anaconda/booty/x86.py", line 535, in write
:    not self.useGrubVal)
:  File "/usr/lib/anaconda/bootloader.py", line 238, in writeBootloader
:    kernelList, otherList, defaultDev)
:  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1388, in nextClicked
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib/anaconda/gui.py", line 1409, in handleRenderCallback
:    self.currentWindow.renderCallback()
:NameError: global name 'log' is not defined
Comment 2 Petr Janda 2013-06-17 07:09:04 EDT
Created attachment 762003 [details]
anaconda-tb-wpAmTh
Comment 3 Petr Janda 2013-06-17 07:26:17 EDT
Steps to reproduce:

1. On HDD old installation including EFI partition exists
2. Start new installation
3. Select "Custom partitioning"
4. Select proper partition/lvm for reformat as / DONOT select any EFI partition
5. Continue

Current result
- anaconda does not complain about missing EFI partition
- anaconda fails with attached traceback during bootloader installation

Expected result
- anaconda doesn`t continue without EFI partition
Comment 4 Samantha N. Bueno 2013-07-11 09:08:32 EDT
The traceback is occurring not because of the missing EFI partition, but because someone added a log statement and forgot to import our logging module.

Regardless, this missed the cut-off for 6.5; pushing off to 6.6 planning.
Comment 5 Brian Lane 2014-06-04 13:40:22 EDT
Created attachment 902270 [details]
untested patch
Comment 6 RHEL Product and Program Management 2014-06-04 13:50:12 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 7 Petr Janda 2014-06-16 07:46:09 EDT
Created attachment 909095 [details]
traceback - anaconda-13.21.220

Some change happened. Installation still ends with traceback but it differs (see attachment please).
Comment 8 Brian Lane 2014-06-16 14:53:03 EDT
Looks like you are now hitting bug 991620
Comment 9 Petr Janda 2014-06-17 04:26:57 EDT
Yes, it looks like it. Although there is no more logs or at least information it is UEFI machine.

Let`s consider this (974996) bug solved and continue with bug 991620.
I will add information there.
Comment 11 Petr Janda 2014-09-10 07:21:17 EDT
verified on RHEL-6.6-20140903.0
anaconda 13.21.227
Comment 12 errata-xmlrpc 2014-10-14 02:39:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1380.html

Note You need to log in before you can comment on or make changes to this bug.