Bug 975007 - cinder-volume fails to start if launched before the volume group is activated
cinder-volume fails to start if launched before the volume group is activated
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: rc
: 3.0
Assigned To: Martin Magr
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 07:29 EDT by Giulio Fidente
Modified: 2016-04-26 09:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.19.dev632.el6ost
Doc Type: Bug Fix
Doc Text:
The Block Storage service (openstack-cinder-volumes) is initialized earlier in the boot process than items listed in the rc.local file. On systems deployed by PackStack and configured to use a volume group backed by loopback device for block storage this meant that the volume group was not available when the Block Storage service was started on boot. As a result the service would fail to start. PackStack has been updated and now ensures that the Block Storage service is restarted once the rc.local file is processed and the volume group is available. This ensures that the Block Storage service continues to function correctly following reboot.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 13:17:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 33305 None None None Never

  None (edit)
Description Giulio Fidente 2013-06-17 07:29:57 EDT
Description of problem:
when installing via packstack, after a reboot, the openstack-cinder-volume service fails to start with:

> VolumeBackendAPIException: Bad or unexpected response from the storage volume backend API: volume group cinder-volumes doesn't exist

later in the boot process rc.local enables the volume group as expected, so a service restart fixes this


Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.17.dev631.el6ost.noarch
openstack-cinder-2013.1.2-3.el6ost.noarch


Steps to Reproduce:
1. install using packstack and using a loopback file for cinder lvm
2. reboot


Actual results:
cinder-volume service is not active
Comment 2 Martin Magr 2013-06-17 09:16:00 EDT
Solution on Packstack side could be:
<mmagr> giulivo, so what do you suggest? add service restart to rc.local?
<giulivo> oh 
<giulivo> yeah that is simple and effective :)
<giulivo> packstack could do it, if using a loopback device
Comment 3 Stephen Gordon 2013-06-18 11:36:59 EDT
This is marked as a blocker, does this mean this note will no longer apply at GA (fix will be included in the release)?
Comment 5 Giulio Fidente 2013-06-19 09:21:11 EDT
verified using openstack-packstack-2013.1.1-0.19.dev632.el6ost.noarch
Comment 7 errata-xmlrpc 2013-06-27 13:17:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.