Bug 975059 - python-dmidecode produces invalid XML data on some hardware
python-dmidecode produces invalid XML data on some hardware
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ales Ledvinka
qe-baseos-daemons
: ZStream
Depends On: 949036
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 10:20 EDT by Jan Kurik
Modified: 2016-09-20 00:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On some hardware, the DMI tables contain data which makes python-dmidecode generate XML tags with duplicated "dmispec" attributes. In some cases, when running the XML data through xmllint or other XML libraries, it failed to parse the data. This update corrects the duplicate "installed" and "dmispec" attributes, and data parsing no longer fails in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 09:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-06-17 10:20:56 EDT
This bug has been copied from bug #949036 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 10 errata-xmlrpc 2013-06-27 09:32:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0989.html

Note You need to log in before you can comment on or make changes to this bug.