Bug 975067 - Unable to select SSD as install drive on F19 Beta
Unable to select SSD as install drive on F19 Beta
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 10:35 EDT by Netbulae
Modified: 2013-06-20 10:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 10:42:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requeste anaconda log (350.58 KB, text/plain)
2013-06-18 06:26 EDT, Netbulae
no flags Details

  None (edit)
Description Netbulae 2013-06-17 10:35:56 EDT
Description of problem:

I'm trying to install F19 Beta on a Samsung 830 SSD, but during install I am only able to select my HDD.

Before I get to the selection menu and after the language selection, I get an error about something in Timbuktu with on of the dialog options "Get out of here"

I cannot remember the exact wording but it looks more like a bit out of the hitchhiker guide to the galaxy then an actual useful error message :-&

Version-Release number of selected component (if applicable):
F19 Beta 1

How reproducible:
Tried it a couple of times, also with a different SSD of the same type. I also did a dd if=/dev/zero, to no avail.
Comment 1 David Lehman 2013-06-17 13:33:19 EDT
Please follow the procedure outlined below to collect some information to help us diagnose your problem:

1. reproduce the problem (get to the point where your ssd is not shown during disk selection)
2. switch to the shell on tty2 by pressing ctrl+alt+f2
3. run the following command to generate a file containing the necessary data:

    kill -USR2 `cat /var/run/anaconda.pid`

    (you can find this command in the shell's history by pressing the up arrow
     several times once in the shell)
4. transfer all files matching /tmp/anaconda-tb-* somewhere from whence you
   can add them to this bug reports as attachments

   NOTE: there will most likely only be one file to attach
Comment 2 Netbulae 2013-06-18 06:26:58 EDT
Created attachment 762461 [details]
Requeste anaconda log
Comment 3 David Lehman 2013-06-18 10:43:13 EDT
Your SSD is, for some reason, configured to be in a firmware-RAID array. The Fedora tools for working with such arrays seem to be having trouble with yours:

11:57:51,989 INFO kernel:[   27.563464] dmraid[746]: segfault at 0 ip 00007f1cc9b4d1ef sp 00007fff1508cd58 error 4 in libc-2.17.so[7f1cc9abd000+1b5000]


Perhaps you could run the following commands and attach the full output to this bug:

 dmraid -v -r
 dmraid -v -s

Thanks in advance.
Comment 4 Netbulae 2013-06-20 08:56:03 EDT
Thanks, that was the problem. One of my co-workers used them for benchmarking a RAID array and put them back on the shelf...

I created a new partition table with gparted.

Do you still need the output? I have some more of these SSD's laying around.
Comment 5 David Lehman 2013-06-20 10:42:04 EDT
I don't need the output since you have verified my suspicion is correct. This is a common problem, and one that there is no simple solution to other than teaching people to correctly wipe raid metadata from their disks when moving them from one system to another. Thanks for reporting back.

Note You need to log in before you can comment on or make changes to this bug.