Bug 975078 - iwlwifi: firmware crashing when connecting to hotspot (Nokia N9)
Summary: iwlwifi: firmware crashing when connecting to hotspot (Nokia N9)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-17 15:15 UTC by Yann Droneaud
Modified: 2014-03-30 03:04 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-27 10:49:45 UTC
Type: Bug


Attachments (Terms of Use)
an extract of dmesg (296.55 KB, text/x-log)
2013-06-17 15:15 UTC, Yann Droneaud
no flags Details

Description Yann Droneaud 2013-06-17 15:15:21 UTC
Created attachment 762068 [details]
an extract of dmesg

Hi,

I'm getting stuck many times not being able to use the hotspot provided by my smartphone (Nokia N9).

Many errors are reported by the firmware and the kernel.

This is not a regression, since the connection was already unreliable in Fedora 17. But it became unusable in Fedora 19.

Some of the error messages:

iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
iwlwifi 0000:03:00.0: Microcode SW error detected.  Restarting 0x2000000.
iwlwifi 0000:03:00.0: Loaded firmware version: 18.168.6.1
iwlwifi 0000:03:00.0: FW error in SYNC CMD REPLY_RXON
iwlwifi 0000:03:00.0: Error clearing ASSOC_MSK on BSS (-5)
WARNING: at drivers/net/wireless/iwlwifi/dvm/mac80211.c:1610 iwlagn_mac_change_interface+0x193/0x1e0 [iwldvm]()
iwlwifi 0000:03:00.0: Microcode SW error detected.  Restarting 0x82000000.
iwlwifi 0000:03:00.0: Unable to initialize device.
iwlwifi 0000:03:00.0: Request scan called when driver not ready.
iwlwifi 0000:03:00.0: Command COEX_PRIORITY_TABLE_CMD failed: FW Error
iwlwifi 0000:03:00.0: Could not complete ALIVE transition: -5
iwlwifi 0000:03:00.0: Failed to start RT ucode: -5
iwlwifi 0000:03:00.0: Unable to find TIM Element in beacon
iwlwifi 0000:03:00.0: REPLY_REMOVE_STA failed

Please have a look to the 'big' dmesg report.

Regards.

Comment 1 Stanislaw Gruszka 2013-08-23 07:49:38 UTC
We don't have N9 to reproduce. Please do the following:

Add this line in /etc/rsyslog.conf: 
kern.*                                                  /var/log/kernel

Restart rsyslog:
# systemctl restart rsyslog.service

Reload module with verbose debug option to grab messages:
# modprobe -r iwldvm
# echo > /var/log/kernel
# modprobe iwlwifi debug=0x47ffffff

Reproduce the problem.

Unload module
# modprobe -r iwldvm

Then please provide /var/log/kernel file.

Comment 2 Josh Boyer 2013-09-18 20:27:50 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 3 Emmanuel Grumbach 2013-09-19 19:18:44 UTC
It seems that you are connecting to an IBSS on a channel that is not allowed because of regulatory issues.
Can you please choose a different channel (1 to 11 prefereably) and report back?

Thanks

Comment 4 Yann Droneaud 2013-09-27 08:24:31 UTC
Hi,

I wasn't able to reproduce the problem recently. I've tried debug setup proposed in comment #1.

Either various kernel and firmware updates fixed my problem, either the environment changed so that I'm not facing the issue.

For the record, I'm in France and the Nokia N9 hotspot utility propose only channels 6, 11 or automatic.

Regards.

Comment 5 Stanislaw Gruszka 2013-09-27 10:49:45 UTC
Closing per above comment.


Note You need to log in before you can comment on or make changes to this bug.