Bug 975166 - node-installer: unable to override tftp_servername parameter
node-installer: unable to override tftp_servername parameter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Dominic Cleal
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 14:18 EDT by Corey Welton
Modified: 2014-04-24 13:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-06-17 14:18:26 EDT
Description of problem:
When user enters a specified servername in foreman-proxy-configure, it is not getting populated within the yaml file for foreman-proxy, rather opting to use the FQDN of $server. This results in users sometimes being unable to provision a system (though why it can't resolve its own hostname is another question)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Install katello+foreman; modify all necessary config files
2.  Run the following command
foreman-proxy-configure -db --servername 192.168.100.1 --port 9090 --puppet true --puppetca false --dhcp true  --dhcp-interface virbr1 --dns false --dns-interface false --tftp true
3. View /etc/foreman-proxy/settings.yml
3.  Populate all the necessary provisioning bits and attempt to populate a host.

Actual results:
* settings.yml shows the tftp servername reference pointing to the fqdn of server:
:tftp_servername: ibm-x3550m3-11.lab.eng.brq.redhat.com

Provisioning of host fails with a notice about being unable to resolve hostname -- which is actually the same hostname as server itself.


Expected results:
Should probably be properly populating servername references with that specified in foreman-proxy-config
Failing that, we probably should be able to resolve our own hostname even if an IP address isn't entered.

Additional info:
* Seen by katello dev and QE
* Workaround is to change tftp_servername to reference either physical IP or the servername referenced in foreman-proxy-configure


* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10011-1.noarch
* foreman-compute-1.1.10011-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10011-1.noarch
* foreman-postgresql-1.1.10011-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-14.el6sat.noarch
* katello-all-1.4.2-14.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-14.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-14.el6sat.noarch
* katello-glue-candlepin-1.4.2-14.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
* katello-glue-pulp-1.4.2-14.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
* pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
* pulp-server-2.1.2-0.3.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.18-1.el6sat.noarch
* signo-katello-0.0.18-1.el6sat.noarch
Comment 1 Corey Welton 2013-06-17 14:20:41 EDT
note: the inability for the server to resolve its own hostname may be a different bug, and/or may be something else entirely (misconfigured systems?!). But it has been seen multiple times now.
Comment 3 Dominic Cleal 2013-09-20 07:28:51 EDT
The tftp_servername was hardcoded in foreman-proxy-configure to the hostname of the system, --servername wasn't intended to override that as far as I can tell.

foreman-proxy-configure has been replaced by node-installer, which doesn't expose this parameter of the foreman_proxy class, so I'm going to leave this issue open as a request to be able to override it.
Comment 4 Dominic Cleal 2013-10-02 05:21:50 EDT
https://github.com/Katello/node-installer/pull/2
Comment 5 Dominic Cleal 2013-10-02 09:12:04 EDT
Upstream in 0.0.15-1.
Comment 8 Corey Welton 2013-10-24 09:52:58 EDT
QA Verified in Satellite-6.0.2-RHEL-6-20131021.0
Comment 11 Bryan Kearney 2014-04-24 13:11:00 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 12 Bryan Kearney 2014-04-24 13:12:03 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.