Bug 975174 - Cartridge migrations should skip cartridges for which manifest does not match gear layout
Cartridge migrations should skip cartridges for which manifest does not match...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 14:30 EDT by Paul Morie
Modified: 2015-05-14 19:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:56:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-06-17 14:30:59 EDT
Currently if the cartridge manifest does not match the gear layout, the migration will fail because it will construct an invalid path to a cartridge.  Instead, we should skip the migration for that cartridge and log a note.
Comment 1 Paul Morie 2013-06-17 16:24:17 EDT
PRs submitted to master and stage.
Comment 2 openshift-github-bot 2013-06-17 17:58:04 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/ceaf3cfeacd529ac3e833ec389a503f4285fa632
Fix bug 975174: skip migration for cartridges when manifest does not match gear layout
Comment 3 Paul Morie 2013-06-17 18:20:15 EDT
Will be in devenv 3373
Comment 4 Jianwei Hou 2013-06-18 07:29:35 EDT
Verified on devenv_3375

Create an application, rename the cartridge dir, making which inconsistent with its manifest.yml, then migrate the gear. The cartridge will be skipped.

rhc-admin-migrate --version 2.0.29 --login jhou+1@redhat.com --app-name skip --migrate-gear 51c03b76b2564e03a1000002
Migrating gear on node with: /usr/bin/rhc-admin-migrate --login 'jhou+1@redhat.com' --migrate-gear '51c03b76b2564e03a1000002' --app-name 'skip' --version '2.0.29' 
Migrating on node...
***time_migrate_on_node_measured_from_broker=955***
Migrate on node output:
 Beginning 2.0.29 migration for 51c03b76b2564e03a1000002
Inspecting gear at /var/lib/openshift/51c03b76b2564e03a1000002
Pre-migration state: started
Marking step inspect_gear_state complete
Migrating gear at /var/lib/openshift/51c03b76b2564e03a1000002
Skipping migration for diy: cartridge manifest does not match gear layout: /var/lib/openshift/51c03b76b2564e03a1000002/diy is not a directory
Cleaning up after migration
***time_migrate_on_node_measured_from_node=382***
***time_redeploy_httpd_proxy=0***
***time_restart=0***
***time_total_migrate_gear_measured_from_broker=961***

Note You need to log in before you can comment on or make changes to this bug.