Bug 975199 - mate-screenshot ignores directory where to save files
mate-screenshot ignores directory where to save files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-utils (Show other bugs)
18
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 15:25 EDT by pgaltieri
Modified: 2013-07-20 05:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-utils-1.6.0-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pgaltieri 2013-06-17 15:25:29 EDT
Description of problem:
When you save a screenshot taken with mate-screenshot it ignores the directory where to save files and always puts the image on the desktop.

Version-Release number of selected component (if applicable):
mate-utils-1.6.0-1.fc18.i686

How reproducible:
Always

Steps to Reproduce:
1. run mate-screenshot
2. take screenshot
3. when it presents the "Save Screenshot" dialog change the "Save in Folder" to something other than desktop, and click save.  

Actual results:
The picture appears on the desktop.

Expected results:
The picture should appear in the directory selected.

Additional info:
gnome-screenshot works correctly.
Comment 1 Dan Mashal 2013-06-17 15:42:20 EDT
Try "su -c 'yum install mate-take-screenshot --enablerepo=updates-testing'"
Comment 2 Wolfgang Ulbrich 2013-07-08 09:46:53 EDT
Can you install mate-utils-1.6.0-4.fc18 or mate-screenshot-1.6.0-4.fc18.x86_64 from updates-testing-repo?
With this version i can save a image in any other folder.
Can you confirm?
Comment 3 pgaltieri 2013-07-08 13:24:06 EDT
I tried the 32bit versions of mate-utils and mate-screenshot from the updates-testing repo and I observed the same wrong behavior in both.  I would select Pictures as my destination folder from the pull down list and the pictures would show up on my desktop.
Comment 4 Wolfgang Ulbrich 2013-07-08 13:51:20 EDT
Ok,
i can confirm if i select a folder or a drive it save the screenshot in desktop folder.
But further i tested to select others in dropdown list, and here it works.
Can you confirm again?
Comment 5 pgaltieri 2013-07-08 14:06:46 EDT
Here's some additional information.  If I select "Other" in the "Save in folder" pulldown and explicitly select "Pictures" as the destination folder then it correctly saves the file in the Pictures directory.  If I select Pictures from the pulldown and the previous save directory was, for example, Downloads then the file will be saved in Downloads not in Pictures.  In other words to select a folder where to save the file you have to select "Other" first and then select the directory where you want to save the file.
Comment 6 Wolfgang Ulbrich 2013-07-08 16:14:53 EDT
Thanks for traking down more the issue.
https://github.com/mate-desktop/mate-utils/issues/32
Comment 7 Fedora Update System 2013-07-11 12:08:27 EDT
mate-utils-1.6.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-utils-1.6.0-5.fc18
Comment 8 Fedora Update System 2013-07-11 23:01:24 EDT
Package mate-utils-1.6.0-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-utils-1.6.0-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12782/mate-utils-1.6.0-5.fc18
then log in and leave karma (feedback).
Comment 9 Wolfgang Ulbrich 2013-07-12 15:12:40 EDT
Thanks for giving karma.
I did read your comment. I quess you didn't update mate-screenshot also to 1.6.0-5.
We did split mate-utils in a main package which includes
- mate-dictionary
- mate-search-tool
- mate-screenshot
- mate-disk-usage-analyzer
and create single packages of them.
The reason for that is to give the user the opportunity to choose install the main package or only install a needed single package.
But installing both the main package and every single package is possible without any yum conflict if you use the same version no. from updates-testing.
Comment 10 Fedora Update System 2013-07-20 05:51:01 EDT
mate-utils-1.6.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.