Bug 975249 - /usr/bin/nova-novncproxy seems to hang on vnc connection
/usr/bin/nova-novncproxy seems to hang on vnc connection
Status: CLOSED DUPLICATE of bug 974846
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Nikola Dipanov
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 18:22 EDT by Graeme Gillies
Modified: 2016-04-22 01:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 06:40:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme Gillies 2013-06-17 18:22:47 EDT
Hi,

I have openstack setup in the following configuration

2 x cloud controllers running openstack-nova-novncproxy with haproxy in front of them load balancing port 6080

1 x compute node

I have the following setup on each node

controller-01 node nova.conf:
novncproxy_host=openstack-controller-01.fqdn
novncproxy_port=6080
novncproxy_base_url=http://openstack-controller-vip.fqdn:6080/vnc_auto.html
vncserver_proxyclient_address=openstack-controller-01.fqdn
vnc_enabled=True

controller-02 node nova.conf:
novncproxy_host=openstack-controller-02.fqdn
novncproxy_port=6080
novncproxy_base_url=http://openstack-controller-vip.fqdn:6080/vnc_auto.html
vncserver_proxyclient_address=openstack-controller-02.fqdn
vnc_enabled=True

compute-01 node nova.conf
novncproxy_host=openstack-compute-01.fqdn
novncproxy_port=6080
novncproxy_base_url=http://openstack-controller-vip.fqdn:6080/vnc_auto.html
vncserver_listen=0.0.0.0
vncserver_proxyclient_address=openstack-compute-01.fqdn
vnc_enabled=True

When I go to the vnc screen in horizon the bar at the top of the vnc session goes yellow saying "Starting VNC Handshake" before eventually timing out to "Failed to connect to server (code 1006). I've checked all connectivity (controller to compute, and cleint browser to controller) and it all seems to be ok.

When I run /usr/bin/nova-novncproxy in the foreground and attempt to connect to it, it never mentions that it's attempting a connection back to somewhere else, all it shows is

WebSocket server settings:
  - Listen on openstack-controller-01.fqdn:6080
  - Flash security policy server
  - Web server. Web root: /usr/share/novnc
  - No SSL/TLS support (no cert file)
  - proxying from openstack-controller-01.fqdn:6080 to ignore:ignore

  1: 10.10.150.11: ignoring empty handshake
  2: 10.10.150.11: ignoring empty handshake
  3: 10.10.150.11: ignoring empty handshake
  4: 10.10.150.11: ignoring empty handshake
  5: 10.10.150.11: ignoring empty handshake
  6: 10.10.150.11: ignoring empty handshake
  7: 10.10.150.11: ignoring empty handshake
  9: 10.10.150.11: ignoring empty handshake
 10: 10.10.150.11: Plain non-SSL (ws://) WebSocket connection
 10: 10.10.150.11: Version hybi-13, base64: 'True'
 10: 10.10.150.11: Path: '/websockify'
 11: 10.10.150.11: ignoring empty handshake
 12: 10.10.150.11: ignoring empty handshake
 13: 10.10.150.11: ignoring empty handshake
 14: 10.10.150.11: ignoring empty handshake
 15: 10.10.150.11: ignoring empty handshake
 16: 10.10.150.11: ignoring empty handshake

The empty handshake I think are polls from haproxy testing if it's still up. You can see it detects my browser connecting via non ssl, but then never mentions trying to make a connection back to the vm vnc session itself.
Comment 2 Alan Pevec 2013-06-18 06:40:59 EDT

*** This bug has been marked as a duplicate of bug 974846 ***

Note You need to log in before you can comment on or make changes to this bug.