Bug 975283 - Web editor sluggish after latest update
Web editor sluggish after latest update
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
Misty Stanley-Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 22:34 EDT by Misty Stanley-Jones
Modified: 2014-06-18 03:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:23:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2013-06-17 22:34:05 EDT
The web editor is sluggish (in Firefox) after the latest update. I suspect this is because of the on-the-fly DTD validation. Chrome does not seem to be affected.
Comment 1 Lee Newson 2013-06-17 22:53:31 EDT
FWIW, this is much easier to see as the topic gets larger. For really large topics the delay for keystrokes to render (or other actions) can be a few seconds.

Perhaps having a validate button would be better in this case, so that way it's less background work, as at the moment we have three core components working in the background (spelling, validation and rendering). The other option that springs to mind is a toggle to turn the validation on or off. I'm not sure how valid these options are though as I'm not familiar with the specific implementation.
Comment 2 Matthew Casperson 2013-06-18 23:50:24 EDT
Fixed in 201306191339

The spell checking is now done in a web worker. Firefox is still slower than chrome (copying data back and forth between the ui thread and the spell checking thread is slow in Firefox), but you don't get the freezes in large topics.

NOTE:
When QAing bug fixes, please make sure the build you are using is equal to or higher than the build identified above. Be aware that this fix may have only been applied in PressGang Next at this time, or it may not be currently applied in any production system, in which case it can only be verified at a later date.
Comment 3 Lee Newson 2013-10-09 01:23:57 EDT
Moving this bug to CLOSED CURRENT_RELEASE to clean up old bugs that were QA'd
by the PressGang team but not by the original reporter. If the bug is still present then please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.