Bug 9753 - was: Emacs DTD bug; now: psgml errors
was: Emacs DTD bug; now: psgml errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: psgml (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 10:27 EST by Sandra Moore
Modified: 2014-08-04 18:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-04 03:42:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandra Moore 2000-02-24 10:27:53 EST
Here is the general problem using emacs-20.5.7:

I open up an emacs session parse a DTD and save it once parsed.
For that session, the DTD is fine and works without a problem.

If I close the emacs session and open another session and try to use the
DTD just created, I get this error in the minibuffer window:

 Args out of range: {\#PCDATA REFSECT3 TOCLEVEL2 REFENTRYTITLE CITATION
 REFSECT2

I'm not sure if it is an SMGL tools problem or emacs, but it happens every
time I try to load a parsed DTD that was not created in that particular
emacs session.
Comment 1 Sandra Moore 2000-04-04 16:19:59 EDT
Ok - this realy isn't an emacs problem, or so we have determined. Removing the
current psgml packages and installing psgml 1.0.3 from the docbook-tools page
allows for correct parsing within the new emacs version.

So what we have is a psgml package problem.

using an old psgml.rpm is a quick fix, but we need to make sure that we can make
a permanent fix with all the correct tools and such for the latest version.
Comment 2 Tim Waugh 2000-10-03 10:45:14 EDT
Do you still get this with Red Hat Linux 7?
Comment 3 Ed Bailey 2000-10-03 12:05:05 EDT
Yup, still happens in 7.0.
Comment 4 Bill Nottingham 2000-10-04 11:14:21 EDT
FWIW, Tim, I spent about 2-3 days trying to track this down
at some point between 6.2 and 7.0.

Something changed between psgml-1.0.3 and psgml-1.1.4 (I think)
that broke it, but I can't for the life of me figure out *what*.
I sent mail to the psgml author, but I haven't heard anything.
Comment 5 Tim Waugh 2000-10-09 10:40:21 EDT
I can't even reproduce this!

Here's what I'm doing (please tell me what I'm doing wrong!):

Fire up emacs (I have emacs-20.7-14 and psgml-1.2.1-8)
Load an SGML file (I'm using a DocBook one)
Press tab somewhere in the middle to cause it to parse the DTD
Using the menubar, DTD->Save Parsed DTD
Accept the suggested filename
Quit emacs
Fire up emacs again
Load the same SGML file
Press tab somewhere in the middle.

It works for me..
Comment 6 Ed Bailey 2000-10-20 11:20:07 EDT
Ok, I've got the same emacs and psgml RPMs loaded on my 7.0 box.  Here are the
steps I folow:

I launch Emacs.

I open a DocBook 3.0 file (this file has a DocBook 3.0 DTD line at the top; it
is a "book" document).

I parse the DTD by doing a C-c C-p.

I then select "DTD > Save Parsed DTD" from Emacs' menu.

I am prompted for a filename; I choose docbook.ced.

I then exit Emacs.

I relaunch Emacs, and open another DocBook 3.0 file (this file has no DTD line
at the top; it starts with a <chapter> tag).

I select "DTD > Load Parsed DTD" from Emacs' menu.

I am prompted for a filename; I choose docbook.ced.

After a short delay, I get a beep, and Emacs' minibuffer contains:
"Args out of range: [\#PCDATA REFSECT3 TOCLEVEL2 REFENTRYTITLE CITATION REFSECT2
TOCLEVEL1 TOCPART SETINFO SEGMENTEDLIST], 1353798"
(This is all on one line, and is usually truncated by Emacs' window size.)

I think the reason you were not seeing the bug is due to the fact that you were
opening the original file the second time.  The steps I've outlined have worked
prior to this version of psgml; it reliably fails now...
Comment 7 Ed Bailey 2001-01-22 14:11:53 EST
FYI -- This bug only seems to affect DocBook 3.0 documents.  I just changed one
of our documents to use the 3.1 DTD (ie, just changed the DTD line), and the
latest version of psgml worked just fine...

So we might be in the position of having technology pass this bug by... :-)
Comment 8 schulz 2001-02-16 09:56:09 EST
Another thing related to both (x)emacs and sgml that obviously went wrong 
during packaging is some malfunction of the html mode within xemacs. 

Actually, when opening an html file, xemacs presents some skeleton to fill 
with the text you like, but it cannot read the doctype line it has created
itself. Version information is included below:

 rpm -qi xemacs
Name        : xemacs                       Relocations: (not relocateable)
Version     : 21.1.14                           Vendor: Red Hat, Inc.
Release     : 2.7                           Build Date: Mon 05 Feb 2001 07:28:37
PM CET
Install date: Thu 08 Feb 2001 09:23:37 AM CET      Build Host: porky.devel.redha


I searched the reason and found a problem with a sgml-catalouge file. I dont 
know much about the details, however for me, a quick solution is to put the
following in the .emacs file:


(setq sgml-catalog-files 
      '("CATALOG" "/usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG"))


However, in my opinion this should be fixed in the default configutation file 
contained in the rpm.

Yours,
	Martin Schulz
Comment 9 Tim Waugh 2001-04-02 06:38:49 EDT
Martin, I think this is a different bug altogether (bug #28198).
Comment 10 Tim Waugh 2001-09-11 07:46:32 EDT
I can no longer reproduce this.

psgml-1.2.1-13
emacs-20.7-41

I think it must be fixed.

Note You need to log in before you can comment on or make changes to this bug.