Bug 9754 - Can't use 3C905C-TX with RedHat 6.1
Can't use 3C905C-TX with RedHat 6.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-24 11:22 EST by Paul A. Bennett
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-22 15:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul A. Bennett 2000-02-24 11:22:31 EST
Hello!

I've just received my new Gateway E5200-500.  It contains a 3C905C-TX
network card.

I noticed that if I ping out from this machine to other machines on my home
network, latency varies widely from about 1 ms to > 147 ms and several
packets are dropped.  If I telnet (or rsh) into this machine, the
connection only survives a few seconds until it hangs, then is eventually
lost.

In reading newsgroups, I realize there seems to be generalized problems
with the 3C905* series of network adapters.  Nonetheless, I followed the
advice.  I donwloaded the recommended 3Com driver, compiled and installed
it (with SMP).

I also booted up DOS and tried to run 3C90XCFG.EXE to turn of PnP as
recommended by one post.  The first 3C90XCFG.EXE I tried couldn't find the
card in the machine.  When I tried the 3C90XCFG.EXE that came with the
machine, it found the card but made no mention of PnP.

In the BIOS, PnP is turned off.

The only thing I noticed was that the 3C905C-TX appears to share an IRQ
with the IR system.  I have no idea how to change the IRQ on the 3C905C-TX
as the 3C90XCFG.EXE won't let me change the IRQ.  I have no idea if
changing the IR's IRQ would help nor how to do it.  In fact, I don't want
to if I don't have to.

All I want to do is to get my network card running properly.

Can you please help!!!

Thanks.

Paul
Comment 1 Jeff Johnson 2000-05-15 06:25:59 EDT
This is a kernel driver problem. Changing component ...
Comment 2 Alan Cox 2000-08-08 16:01:44 EDT
This card should work ok in 6.2

Note You need to log in before you can comment on or make changes to this bug.