Bug 975405 - Firefox is freezing in krb5/gethostbyname()
Firefox is freezing in krb5/gethostbyname()
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 07:52 EDT by David Jaša
Modified: 2015-01-06 06:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-06 06:09:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1014061 None None None Never

  None (edit)
Description David Jaša 2013-06-18 07:52:48 EDT
Description of problem:
Firefox is not responding for tens of seconds when connecting to some sites. I didn't find a reliable pattern, I have just these clues:
  * it may be more frequent when connecting to kerberized sites
  * based on tab header, the hiccup occurs after the name is resolved to IP (favicon stops spinning to left, freeze, page loads)

Version-Release number of selected component (if applicable):
firefox-17.0.6-1.el6_4.x86_64
xulrunner-17.0.6-2.el6_4.x86_64
note: I started noticing this behaviour sometimes since FF 4.0

How reproducible:
no real reproducer, sometimes frequent, mostly not at all

Steps to Reproduce:
1. connect to some site
2.
3.

Actual results:
firefox hangs temporarily for quite a long time. No window can be used.

Expected results:
firefox loads the page instantly

Additional info:
I'll attach bt of $(pidof firefox) process. If you need anything else, please request it.
Comment 2 Martin Stransky 2013-10-08 09:52:21 EDT
The main tread waits in krb5_sendto_kdc(), in deep in _nss_dns_gethostbyname4_r() which looks like some resolving problem.
Comment 3 Martin Stransky 2013-10-08 09:56:32 EDT
Unfortunately, there isn't any easyfix for that. It needs to move the krb code to another thread and make it async.
Comment 4 RHEL Product and Program Management 2013-10-13 23:20:35 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Martin Stransky 2015-01-06 06:09:52 EST
Upstream bug - https://bugzilla.mozilla.org/show_bug.cgi?id=1014061

Note You need to log in before you can comment on or make changes to this bug.