Bug 975427 - One can create custom channels with Debian-specific architectures
One can create custom channels with Debian-specific architectures
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2013-06-18 09:01 EDT by Jiří Mikulka
Modified: 2014-10-06 09:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 05:09:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-06-18 09:01:04 EDT
Description of problem:
One can select Debian related architecture for new custom channe. Debian support was introduced in upstream, but was not intended to be part of Satellite.

Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130617.0
Satellite-5.5.0-RHEL6-re20120911.0
Satellite-5.4.1-RHEL5-re20110615.0

How reproducible:
always (not regression against Satellite 5.5.0 nor 5.4.1, also present there)

Steps to Reproduce:
1. create custom channel (Channels / Manage Software Channels / create new channel)
2. open Architecture select box
3. one can see "* Debian" architectures

Actual results:
3. one can see "* Debian" architectures

Expected results:
3. only architectures for which channels are supported by Red Hat should be shown
Comment 1 Milan Zázrivec 2013-08-07 05:09:04 EDT
The Debian architectures may indeed show on an arbitrary Satellite
as long as you import a channel dump created in Spacewalk, which is
what happened here (part of automated test).

Under normal circumstances (i.e. in customer's environment) this
should not be happening.

Closing -> notabug.

Note You need to log in before you can comment on or make changes to this bug.