Bug 975434 - AMQP 1.0 connections don't take username and password from url
AMQP 1.0 connections don't take username and password from url
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Ernie
:
Depends On:
Blocks: 974061 1010399
  Show dependency treegraph
 
Reported: 2013-06-18 09:11 EDT by Gordon Sim
Modified: 2015-01-21 07:54 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-5.el6, qpid-cpp-0.22-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:54:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4887 None None None Never

  None (edit)
Description Gordon Sim 2013-06-18 09:11:05 EDT
Description of problem:

A url can contain a username and password, but the AMQP 1.0 implementation of qpid::messaging ignores them.

Version-Release number of selected component (if applicable):

qpid 0.22

How reproducible:

100%

Steps to Reproduce:
1. qpid-send --address amq.topic --connection-options {protocol:amqp1.0,sasl_mechanisms:PLAIN} --broker guest/guest@localhost

Actual results:

client does not use supplied username and password to authenticate (and if client restricts itself to PLAIN as it does here, a 'no worthy mechs' error is thrown).

Expected results:

client does use the supplied credentials

Additional info:
Comment 1 Ernie 2013-08-23 14:14:17 EDT
Verified rhel 6.4 x86_64/i686

x86_64:
python-qpid-0.22-4.el6.noarch
python-qpid-qmf-0.22-7.el6.x86_64
qpid-cpp-client-0.22-8.el6.x86_64
qpid-cpp-client-devel-0.22-8.el6.x86_64
qpid-cpp-server-0.22-8.el6.x86_64
qpid-proton-c-0.4-2.2.el6.x86_64
qpid-qmf-0.22-7.el6.x86_64
qpid-tools-0.22-3.el6.noarch

i686:
perl-qpid-0.22-5.el6.i686
python-qpid-0.22-4.el6.noarch
python-qpid-qmf-0.22-7.el6.i686
qpid-cpp-client-0.22-8.el6.i686
qpid-cpp-client-devel-0.22-8.el6.i686
qpid-cpp-client-devel-docs-0.22-8.el6.noarch
qpid-cpp-client-rdma-0.22-8.el6.i686
qpid-cpp-client-ssl-0.22-8.el6.i686
qpid-cpp-debuginfo-0.22-8.el6.i686
qpid-cpp-server-0.22-8.el6.i686
qpid-cpp-server-devel-0.22-8.el6.i686
qpid-cpp-server-ha-0.22-8.el6.i686
qpid-cpp-server-rdma-0.22-8.el6.i686
qpid-cpp-server-ssl-0.22-8.el6.i686
qpid-cpp-server-store-0.22-8.el6.i686
qpid-cpp-server-xml-0.22-8.el6.i686
qpid-cpp-tar-0.22-8.el6.noarch
qpid-java-client-0.22-5.el6.noarch
qpid-java-common-0.22-5.el6.noarch
qpid-java-example-0.22-5.el6.noarch
qpid-proton-c-0.4-2.2.el6.i686
qpid-proton-c-devel-0.4-2.2.el6.i686
qpid-proton-debuginfo-0.4-2.2.el6.i686
qpid-qmf-0.22-7.el6.i686
qpid-qmf-debuginfo-0.22-7.el6.i686
qpid-qmf-devel-0.22-7.el6.i686
qpid-snmpd-1.0.0-12.el6.i686
qpid-snmpd-debuginfo-1.0.0-12.el6.i686
qpid-tests-0.22-4.el6.noarch
qpid-tools-0.22-3.el6.noarch
rh-qpid-cpp-tests-0.22-8.el6.i686
ruby-qpid-qmf-0.22-7.el6.i686

Not reproduced since this is a devel bug.

Note You need to log in before you can comment on or make changes to this bug.