Bug 975440 - Update format of SpiceSecureChannels to "channel" from "schannel"
Update format of SpiceSecureChannels to "channel" from "schannel"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
virt
:
Depends On:
Blocks: 803666
  Show dependency treegraph
 
Reported: 2013-06-18 09:16 EDT by Ravi Nori
Modified: 2014-01-01 03:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 10:39:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravi Nori 2013-06-18 09:16:15 EDT
Description of problem:

Update format of SpiceSecureChannels to "channel" from "schannel". "schannel" (like smain, sinputs etc) is a leftover from qspice 0.3.x from RHEL 5 days, since at least spice 0.6 (maybe even 0.4 from RHEL 6.0), the format is changed to "channel" (main, inputs etc).

Sticking to old format means that converters to new format have to exist in at least three places (vdsm and two browser plugins) that leave unneccessary space for (not a) bugs like bug #803613.

Since RHEL 5 hosts won't be supported by RHEV-M 3.1, there will be no reason to maintain this magic stuff anymore and it will be possible to drop it completely.

vdsm strips off first character when channel is passed to it. We need a fix for vdsm

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Barak 2013-07-25 10:39:32 EDT
As the blocked bug was CLOSED ...
moving to CLOSE WONTFIX

Note You need to log in before you can comment on or make changes to this bug.