Bug 975463 - convert reply-to between 1.0 and 0-10 message formats
convert reply-to between 1.0 and 0-10 message formats
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Petr Matousek
:
Depends On:
Blocks: 974061 1010399
  Show dependency treegraph
 
Reported: 2013-06-18 10:05 EDT by Gordon Sim
Modified: 2015-01-21 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-5.el6, qpid-cpp-0.22-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:57:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4713 None None None Never

  None (edit)
Description Gordon Sim 2013-06-18 10:05:01 EDT
Description of problem:

As of qpid 0.22 the reply-to property in a 1.0 message was not converted into a corresponding 0-10 reply to. This translation is lossy since the formats are quite different, but something better than no conversion at all should be attempted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. ./examples/messaging server
2. ./examples/messaging client {protocol:amq1.0}

Actual results:

client doesn't get responses

Expected results:

client gets responses

Additional info:
Comment 1 Petr Matousek 2013-12-23 14:46:05 EST
This issue has been fixed. Verified on rhel6.5 (x86_64, i386).

packages under test:
qpid-cpp-*-0.22-29

-> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.