Bug 975465 - Crash when opening some PDF documents
Crash when opening some PDF documents
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 10:12 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: poppler-0.22.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:06:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace (19.43 KB, text/plain)
2013-06-18 10:12 EDT, Martin
no flags Details

  None (edit)
Description Martin 2013-06-18 10:12:45 EDT
Created attachment 762509 [details]
GDB backtrace

Description of problem:
Crash when opening some PDF documents

Version-Release number of selected component (if applicable):
evince-3.8.2-1.fc19.x86_64
poppler-0.22.1-3.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
Open PDF document

Actual results:
Evince crash on open

Expected results:
no crash
Comment 2 Marek Kašík 2013-06-20 09:40:44 EDT
Switching dependency from LCMS to LCMS2 fixes the problem. I've pushed it to git and I will prepare an update for this bug.
Comment 3 Fedora Update System 2013-06-20 09:43:22 EDT
poppler-0.22.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/poppler-0.22.1-4.fc19
Comment 4 Martin 2013-06-20 11:40:09 EDT
Fix works for me.
Comment 5 Fedora Update System 2013-06-20 13:57:35 EDT
Package poppler-0.22.1-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing poppler-0.22.1-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11316/poppler-0.22.1-4.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-29 14:06:42 EDT
poppler-0.22.1-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.