Bug 975477 - Tooltips in TicketMonster menus are not displayed correctly
Tooltips in TicketMonster menus are not displayed correctly
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: CR1
: 2.3.0
Assigned To: Pete Muir
Oliver Kišš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 10:39 EDT by Oliver Kišš
Modified: 2015-08-02 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (157.73 KB, image/png)
2013-06-18 10:39 EDT, Oliver Kišš
no flags Details
Fix to correct popover effect (2.01 KB, patch)
2013-06-18 13:15 EDT, Vineet Reynolds
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JDF-381 Major Closed Tooltips in TicketMonster menus are not displayed correctly 2013-09-02 03:14:33 EDT

  None (edit)
Description Oliver Kišš 2013-06-18 10:39:43 EDT
Created attachment 762512 [details]
screenshot

Description of problem:

Tooltips of items in side menus are not displayed correctly (see attached screenshot)

This happens in Firefox 21, Chrome 27 and MSIE10.

Version-Release number of selected component (if applicable):
2.3.0.ER1

Steps to Reproduce:
1. Load TicketMonster page with an accordion side menu
2. Expand a menu item and hover over a subitem
3. See broken tooltip
Comment 1 JBoss JIRA Server 2013-06-18 10:51:19 EDT
Oliver Kišš <okiss@redhat.com> made a comment on jira JDF-381

screenshot
Comment 2 JBoss JIRA Server 2013-06-18 11:31:08 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> made a comment on jira JDF-381

This looks like a Bootstrap 2.3.1 related change made upstream is not present downstream. Specifically, [this line 21|https://github.com/jboss-jdf/ticket-monster/commit/8793e2093cd430e94416f787f7cfb29978d374a0#L17R21] in {{venues.js}} and [line 23|https://github.com/jboss-jdf/ticket-monster/commit/8793e2093cd430e94416f787f7cfb29978d374a0#L16R23] in {{events.js}}.

The {{container:'body'}} expression was introduced to correct this.
Comment 3 Vineet Reynolds 2013-06-18 13:15:48 EDT
Created attachment 762556 [details]
Fix to correct popover effect

This is to fix the bug downstream since it cannot be reproduced upstream. 

The patch restores the fix that was lost in this downstream commit: http://git.app.eng.bos.redhat.com/?p=wfk/ticket-monster.git;a=commit;h=94e64d2477e0c929e0c1691fb598fc67edfe0945
Comment 4 JBoss JIRA Server 2013-06-18 13:17:31 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> updated the status of jira JDF-381 to Closed
Comment 5 JBoss JIRA Server 2013-06-18 13:17:31 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> made a comment on jira JDF-381

This cannot be reproduced upstream, hence any bugfixes will be supplied in the downstream bug.
Comment 6 Marek Novotny 2013-06-19 03:34:53 EDT
Thanks Vineet for catching that downstream rebase issue
Comment 9 Oliver Kišš 2013-07-01 08:01:02 EDT
Verified in CR1

Note You need to log in before you can comment on or make changes to this bug.