Bug 975484 - Some characters no longer allowed in Org names
Some characters no longer allowed in Org names
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Adam Price
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 10:51 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 16:52:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2013-06-18 10:51:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):
1.4.2-1.git.682.7662991.el6

How reproducible:


Steps to Reproduce:
1.  Create an org
2.  As org name enter the following character: ↽
3.

Actual results:
Name cannot contain characters other than alpha numerals, space, '_', '-'

Expected results:
Org created

Additional info:
Other characters do work, eg 䘦 or ᅈ
Seems like the range of allowed characters has been restricted, I am not familiar enough with UTF8 to know whether legitimate names in non-latin languages will be disallowed because of this, but it appears to be the case.
Comment 1 RHEL Product and Program Management 2013-06-18 11:04:52 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Jeff Weiss 2013-06-18 13:53:14 EDT
Note another thing that was broken with the same change in katello, was orgs with a "." in the name.

So another testcase is to create an org called "foo.bar".  It should succeed.
Comment 4 Adam Price 2013-06-18 15:39:56 EDT
everything should be allowed except <, >, and /
Comment 5 Jeff Weiss 2013-06-18 16:52:18 EDT
Superseded by 975593

Note You need to log in before you can comment on or make changes to this bug.