Bug 975487 - Exception on running glanceclient commands with non-ASCII arguments
Exception on running glanceclient commands with non-ASCII arguments
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: beta
: 4.0
Assigned To: Flavio Percoco
Tzach Shefi
: Triaged
Depends On: 965139
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 11:02 EDT by Flavio Percoco
Modified: 2016-04-27 00:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-glanceclient-0.10.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 965139
Environment:
Last Closed: 2013-12-19 19:06:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1200206 None None None Never
OpenStack gerrit 36658 None None None Never

  None (edit)
Comment 4 Jakub Ruzicka 2013-11-20 06:54:47 EST
Fix has been included in glanceclient 0.10.0 which is already packaged.
Comment 6 Tzach Shefi 2013-12-04 08:34:32 EST
Tested\Verfied on: 

Red Hat Enterprise Linux Server release 6.5 (Santiago)

openstack-keystone-2013.2-1.el6ost.noarch
openstack-utils-2013.2-2.el6ost.noarch
openstack-ceilometer-common-2013.2-1.el6ost.noarch
openstack-nova-conductor-2013.2-5.el6ost.noarch
openstack-nova-cert-2013.2-5.el6ost.noarch
redhat-access-plugin-openstack-4.0.0-0.el6ost.noarch
openstack-ceilometer-central-2013.2-1.el6ost.noarch
openstack-ceilometer-api-2013.2-1.el6ost.noarch
openstack-selinux-0.1.3-1.el6ost.noarch
openstack-packstack-2013.2.1-0.11.dev847.el6ost.noarch
openstack-glance-2013.2-3.el6ost.noarch
openstack-nova-api-2013.2-5.el6ost.noarch
openstack-ceilometer-compute-2013.2-1.el6ost.noarch
openstack-nova-console-2013.2-5.el6ost.noarch
openstack-nova-compute-2013.2-5.el6ost.noarch
openstack-nova-scheduler-2013.2-5.el6ost.noarch
openstack-neutron-2013.2-10.el6ost.noarch
openstack-neutron-openvswitch-2013.2-10.el6ost.noarch
python-django-openstack-auth-1.1.2-1.el6ost.noarch
openstack-dashboard-2013.2-5.el6ost.noarch
openstack-nova-common-2013.2-5.el6ost.noarch
openstack-nova-novncproxy-2013.2-5.el6ost.noarch
openstack-dashboard-theme-2013.2-5.el6ost.noarch
openstack-ceilometer-collector-2013.2-1.el6ost.noarch


Sending none ASCII argument now returns a valid “No image with name of ID of...” instead of previous exception error. 


[root@cougar01 ~(keystone_admin)]# glance image-delete הקידב
No image with a name or ID of 'הקידב' exists.
[root@cougar01 ~(keystone_admin)]#
Comment 9 errata-xmlrpc 2013-12-19 19:06:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.