Bug 975508 - perl-qpid has invalid build dependency qpid-cpp-client-devel = 0.22
perl-qpid has invalid build dependency qpid-cpp-client-devel = 0.22
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-qpid (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On: 974783
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 11:56 EDT by Tuomo Soini
Modified: 2015-06-21 20:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 14:04:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2013-06-18 11:56:35 EDT
Description of problem:

perl-qpid has build dependency qpid-cpp-client-devel = 0.22

This is invalid because qpid-cpp = 0.22 shouldn't be in epel, it's part of core rhel6.
Comment 1 Darryl L. Pierce 2013-06-18 12:10:46 EDT
I'm not sure I understand what you mean by "invalid build dependency". perl-qpid 0.22 requires qpid-cpp-client-devel 0.22 which is available in EPEL. This is the currently released version of Qpid.
Comment 2 Tuomo Soini 2013-06-18 12:41:09 EDT
qpid-cpp-client-devel in epel6 testing must not be there!

qpid-cpp-client-devel-0.14-22.el6_3 is part of base os and epel6 can never provide package in rhel6 base os.
Comment 3 Darryl L. Pierce 2013-06-18 13:58:38 EDT
Retired the epel package and unpushed the testing packages.

Note You need to log in before you can comment on or make changes to this bug.