Bug 975523 - cannot change any gnome preferences
cannot change any gnome preferences
Status: CLOSED DUPLICATE of bug 975521
Product: Fedora
Classification: Fedora
Component: dconf (Show other bugs)
19
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 12:54 EDT by Jeff Bastian
Modified: 2013-06-25 09:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 09:11:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2013-06-18 12:54:32 EDT
Description of problem:
I cannot change any settings under the Profile Preferences in gnome-terminal.  For example, I clicked the checkbox to disable "Use the system fixed width font" and it turned off for a split second, then it immediately turned back on.  Likewise with other preferences such as "Allow bold text"


Version-Release number of selected component (if applicable):
gnome-terminal-3.8.3-1.fc19.x86_64

How reproducible:
every time (?) (it happened on my daily system and in a fresh virtual machine)

Steps to Reproduce:
1. launch gnome-terminal
2. go to Edit -> Profile Preferences
3. try to change the font setting

Actual results:
cannot change any settings

Expected results:
allowed to change settings

Additional info:
Comment 1 Christian Persch (GNOME) 2013-06-20 08:29:12 EDT
This is a dconf problem, nothing to do with gnome-terminal itself.
Comment 2 Jeff Bastian 2013-06-24 10:40:59 EDT
Yes, I see now that I cannot change other settings either like the wallpaper.  Moving to dconf.
Comment 3 Jeff Bastian 2013-06-24 10:41:57 EDT
And I cannot add applications to the favorites list in gnome-shell.  My dconf database is acting like it's read-only.
Comment 4 Jeff Bastian 2013-06-25 09:11:30 EDT
The logs contained this error:

Jun 25 08:00:53 tarantula.localdomain /etc/gdm/Xsession[1685]: (gnome-settings-daemon:1900): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code17: Cannot open dconf database: invalid gvdb header


And my dconf database was corrupt (full of nothing but null bytes):

 ~]$ od ~/.config/dconf/user
0000000 000000 000000 000000 000000 000000 000000 000000 000000
*
0077300 000000
0077302


I removed my corrupt db and updated the glib2 package to glib2-2.36.3-2.fc19 and now I can change settings again.

*** This bug has been marked as a duplicate of bug 975521 ***

Note You need to log in before you can comment on or make changes to this bug.