Bug 975542 - Cover the process of creating a new project/tenant and related objects.
Cover the process of creating a new project/tenant and related objects.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: ---
: 5.0 (RHEL 7)
Assigned To: RHOS Documentation Team
ecs-bugs
docs-rhos5-icg-others
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 14:11 EDT by Stephen Gordon
Modified: 2015-02-04 07:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-04 07:22:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-06-18 14:11:47 EDT
There is already a bug to change the service setup procedures to use a "services" tenant or more realistic setup than they currently do (using one tenant for each individual service).

In addition though we also need to cover the creation of a "real" tenant used for user and resource separation, probably with a realistic example. These should cover:

- Creation of the tenant itself.
- Creation of endpoints for the tenant.
- Additional steps required to get a "realistic" deployment, may include network setup, security group setup, etc.
Comment 1 Stephen Gordon 2013-06-24 11:18:30 EDT
NB: This is not to be confused with BZ # 965943 which talks about the initial creation of tenants to facilitate basic environment setup. Here we are talking about more realistic tenants that will be created post install to restrict access to resources and administer quotas.
Comment 2 Summer Long 2013-12-02 18:56:36 EST
Moving to Icehouse, when we can plan resourcing for this.
Comment 3 Don Domingo 2014-02-25 00:58:06 EST
Since this is a post-install procedure for Keystone, reassigning this to Bruce Reeler and changing the component to Admin User Guide.
Comment 4 Bruce Reeler 2014-05-05 02:45:46 EDT
In the upstream Administration User Guide, there is a section under Dashboard and another section under CLI that describe creating and managing tenants ("projects" in dashboard). These sections cover creating tenants, assigning users to tenants, deleting tenants, and managing tenant security, and setting quotas.

Hence the requirements of this bug seem to be covered for 5.0.
Comment 7 Andrew Dahms 2015-02-04 07:22:57 EST
I have confirmed that this content has been added and is now live.

Closing.

Note You need to log in before you can comment on or make changes to this bug.