Bug 975559 - Handler rollback gets null instance reference if prepare are invoked
Handler rollback gets null instance reference if prepare are invoked
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: EAP 6.1.1
Assigned To: James Perkins
:
Depends On:
Blocks: 971618 975555
  Show dependency treegraph
 
Reported: 2013-06-18 14:57 EDT by Kyle Lape
Modified: 2013-09-16 16:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of JBoss EAP 6, a rollback of a composite operation to remove and re-add an Apache log4j appender would fail if the appender's name was staying the same. The rollback of the composite operation would fail because the reference to the previous log4j appender would have already been removed. This issue was fixed by not validating whether the reference to the log4j appender exists, as it may be created later. As a result of this fix, no errors should be seen when a composite operation to remove and re-add an Apache log4j appender is rolled back.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:27:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cdewolf: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker LOGMGR-58 Major Resolved Handler rollback gets null instance reference if prepare are invoked 2014-08-31 22:09:16 EDT

  None (edit)
Description Kyle Lape 2013-06-18 14:57:18 EDT
This is fixed upstream in LOGMGR-58
Comment 1 JBoss JIRA Server 2013-06-19 13:49:50 EDT
James Perkins <jperkins@redhat.com> updated the status of jira LOGMGR-58 to Resolved
Comment 2 JBoss JIRA Server 2013-06-19 13:49:50 EDT
James Perkins <jperkins@redhat.com> made a comment on jira LOGMGR-58

Pull request merged
Comment 4 Carlo de Wolf 2013-07-23 10:47:20 EDT
Upgrade to logmanager 1.4.3.Final is in ER4.
Comment 5 Petr Kremensky 2013-07-31 03:03:41 EDT
Verified on EAP 6.1.1 ER4

Note You need to log in before you can comment on or make changes to this bug.