Bug 975585 - Manually typed Resource name in the "Resource Metric Graph" portlet breaks Dashboards (Globally uncaught exception)
Manually typed Resource name in the "Resource Metric Graph" portlet breaks Da...
Status: CLOSED DUPLICATE of bug 846818
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.2
Unspecified Unspecified
unspecified Severity high
: ---
: JON 3.2.0
Assigned To: Heiko W. Rupp
Mike Foley
Depends On: 918051
  Show dependency treegraph
Reported: 2013-06-18 16:16 EDT by Heiko W. Rupp
Modified: 2013-08-09 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 918051
Last Closed: 2013-08-09 12:22:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2013-06-18 16:16:30 EDT
+++ This bug was initially created as a clone of Bug #918051 +++

Description of problem:
Dashboards become unavailable

Version-Release number of selected component (if applicable):

Steps to Reproduce:
   1. Create new Dashboard
   2. Add "Resource Metric Graph" portlet
   3. Configure portlet, set Resource name from list to "C:\" and Metric to "Free Space", and after manually type "C:\test" into the Resource name. Save.
   4. Relogin.
   Dashboards would be unavailable.
   String value in the RHQ_CONFIG_PROPERTY with name "resourceId" for this portlet would be "C:\test", causing NumberFormatException error (is seems that it expected to be an integer number, not a string).

--- Additional comment from Heiko W. Rupp on 2013-06-18 16:00:17 EDT ---

This is still true with RHQ 4.7 and current master

--- Additional comment from Heiko W. Rupp on 2013-06-18 16:13:42 EDT ---

to get going again, the offending portlet currently needs to be manually removed from the rhq_dashboard_portlets page
Comment 1 Heiko W. Rupp 2013-07-02 06:58:11 EDT
This was solved in master and is part of RHQ 4.8, so will be in JON 3.2
Comment 2 Heiko W. Rupp 2013-08-09 12:22:51 EDT
Turns out this is a dup of 846818

*** This bug has been marked as a duplicate of bug 846818 ***

Note You need to log in before you can comment on or make changes to this bug.