This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 975593 - [RFE] Make name field validation consistent across entities, and use the non-html validator
[RFE] Make name field validation consistent across entities, and use the non-...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Tazim Kolhar
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 16:51 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:08:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2013-06-18 16:51:39 EDT
Right now, the org name validator disallows these characters:  .^&%$# etc plus a lot of UTF8 chars.  This is overly strict.

After discussing on irc, seems to be agreement that all entities' name field should use the "non-html" validator that allows all chars except: <>/
Comment 1 RHEL Product and Program Management 2013-06-18 17:02:47 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Adam Price 2013-07-09 16:37:40 EDT
it has been agreed upon that 'name' should allow all characters, but 'label' should be restricted under the hood.

this may include fixes in the javascript to correctly display special characters.
Comment 4 Payal Godhani 2013-07-11 14:48:53 EDT
https://github.com/Katello/katello/pull/2623
Comment 7 Mike McCune 2013-10-17 17:01:27 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 8 Tazim Kolhar 2014-05-08 02:51:11 EDT
VERIFIED
Comment 9 Bryan Kearney 2014-07-02 10:08:50 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 10 Bryan Kearney 2014-07-02 10:10:18 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0

Note You need to log in before you can comment on or make changes to this bug.