Bug 975605 - [abrt] gtkpod-2.1.3-1.fc19: gtkpod_init: Process /usr/bin/gtkpod was killed by signal 11 (SIGSEGV)
[abrt] gtkpod-2.1.3-1.fc19: gtkpod_init: Process /usr/bin/gtkpod was killed b...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtkpod (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
abrt_hash:4078c4b34a1d6380270208571da...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-18 18:17 EDT by Harold Hiner
Modified: 2013-07-22 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: gtkpod-2.1.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 21:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.33 KB, text/plain)
2013-06-18 18:17 EDT, Harold Hiner
no flags Details
File: cgroup (141 bytes, text/plain)
2013-06-18 18:17 EDT, Harold Hiner
no flags Details
File: core_backtrace (227 bytes, text/plain)
2013-06-18 18:17 EDT, Harold Hiner
no flags Details
File: dso_list (10.26 KB, text/plain)
2013-06-18 18:17 EDT, Harold Hiner
no flags Details
File: environ (1.61 KB, text/plain)
2013-06-18 18:17 EDT, Harold Hiner
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-18 18:18 EDT, Harold Hiner
no flags Details
File: maps (47.47 KB, text/plain)
2013-06-18 18:18 EDT, Harold Hiner
no flags Details
File: open_fds (616 bytes, text/plain)
2013-06-18 18:18 EDT, Harold Hiner
no flags Details
File: proc_pid_status (2.19 KB, text/plain)
2013-06-18 18:18 EDT, Harold Hiner
no flags Details
File: var_log_messages (308 bytes, text/plain)
2013-06-18 18:18 EDT, Harold Hiner
no flags Details
rpmbuild from gtkpod (50.25 KB, text/plain)
2013-07-11 08:01 EDT, Fabien Archambault
no flags Details

  None (edit)
Description Harold Hiner 2013-06-18 18:17:43 EDT
Version-Release number of selected component:
gtkpod-2.1.3-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        gtkpod
crash_function: gtkpod_init
executable:     /usr/bin/gtkpod
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            10000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (1 frames)
 #1 gtkpod_init at gtkpod.c:99
Comment 1 Harold Hiner 2013-06-18 18:17:49 EDT
Created attachment 762656 [details]
File: backtrace
Comment 2 Harold Hiner 2013-06-18 18:17:51 EDT
Created attachment 762657 [details]
File: cgroup
Comment 3 Harold Hiner 2013-06-18 18:17:53 EDT
Created attachment 762658 [details]
File: core_backtrace
Comment 4 Harold Hiner 2013-06-18 18:17:55 EDT
Created attachment 762659 [details]
File: dso_list
Comment 5 Harold Hiner 2013-06-18 18:17:58 EDT
Created attachment 762660 [details]
File: environ
Comment 6 Harold Hiner 2013-06-18 18:18:01 EDT
Created attachment 762661 [details]
File: limits
Comment 7 Harold Hiner 2013-06-18 18:18:03 EDT
Created attachment 762662 [details]
File: maps
Comment 8 Harold Hiner 2013-06-18 18:18:05 EDT
Created attachment 762663 [details]
File: open_fds
Comment 9 Harold Hiner 2013-06-18 18:18:08 EDT
Created attachment 762664 [details]
File: proc_pid_status
Comment 10 Harold Hiner 2013-06-18 18:18:11 EDT
Created attachment 762665 [details]
File: var_log_messages
Comment 11 Fabien Archambault 2013-07-11 08:01:02 EDT
Created attachment 772199 [details]
rpmbuild from gtkpod

Hi,

I have the same issue and I am trying to find where the issue comes from and it seems to be anjuta dependency which is faulty.

I tried to rebuild the src.rpm directly and it fails to build (see attached file).
$ rpm -qa | grep anjuta
anjuta-devel-3.8.4-1.fc19.x86_64
anjuta-3.8.4-1.fc19.x86_64

I am no expert in GTK but seems to miss defining this function: anjuta_shell_notify_exit
Comment 12 Fabien Archambault 2013-07-11 08:14:49 EDT
Hi again,

I have found that some anjuta_shell defined functions are not within the headers between version 3.7.X and 3.8.X in anjuta.
For example, in version 3.7.1, there is in libanjuta/anjuta-shell.h:
void anjuta_shell_notify_exit       (AnjutaShell *shell, GError **error);

Such line is not available in version 3.8.X. I believe there is something that as been depreciated in anjuta? Should this bug be tagged against anjuta?
Comment 13 Gwyn Ciesla 2013-07-11 08:31:44 EDT
Ideally gtkpod should be updated to work with the new anjuta, but there isn't a new release as yet. I'll check it out upstream.
Comment 14 Gwyn Ciesla 2013-07-11 08:36:21 EDT
I posted here:

https://sourceforge.net/p/gtkpod/bugs/315/
Comment 15 Christian Krause 2013-07-11 19:15:01 EDT
The following Patch from archlinux fixes the issue for me: 

https://projects.archlinux.org/svntogit/community.git/tree/gtkpod/trunk/gtkpod-2.1.3-gdl-3.6.patch

It looks like that that anjuta changed the API without changing the SONAME of their library. Otherwise the issue would have been caught earlier due to broken dependencies of the RPM packages.

Jon, if you want me to update gtkpod using the patch above, please let me know.
Comment 16 Stephen Clement 2013-07-12 04:03:24 EDT
The patch above fixes the issue for me as well.
Comment 17 Gwyn Ciesla 2013-07-12 09:03:14 EDT
It's similar to what we had, but updated and a bit more comprehensive.  It works for me, and builds are on their way.
Comment 18 Fedora Update System 2013-07-12 09:26:15 EDT
gtkpod-2.1.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gtkpod-2.1.3-2.fc19
Comment 19 Fedora Update System 2013-07-12 21:54:12 EDT
Package gtkpod-2.1.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtkpod-2.1.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12914/gtkpod-2.1.3-2.fc19
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2013-07-22 21:09:56 EDT
gtkpod-2.1.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.